Exploring ePublisher : Producing Output Using Sample Source Documents and Stationery : Implementing Online Features Using Sample Source Documents and Stationery : Using Sample Adobe FrameMaker Source Documents and Stationery to Implement Online Features
 
Using Sample Adobe FrameMaker Source Documents and Stationery to Implement Online Features
If you use Adobe FrameMaker to author content, you can use the sample Exploring ePublisher Adobe FrameMaker source documents and the sample Exploring ePublisher Stationery to see how you can use ePublisher to quickly and easily implement the following online features:
*Popup windows
*Expand/collapse sections
*Related topics
*Context-sensitive help topics
The following procedure provides an example of how to implement online features in Adobe FrameMaker source documents using unstructured Adobe FrameMaker 7.2. Steps for implementing online features in Adobe FrameMaker may be different in other versions of Adobe FrameMaker.
To implement online features using the sample Exploring ePublisher Adobe FrameMaker source documents and Stationery
1. Create a popup window by completing the following steps:
a. In Document Manager, open the Quick Reference.fm file.
b. In the Exploring ePublisher Sample Content section at the end of the Quick Reference.fm file, apply the GlossTerm paragraph format to the Popup window glossary term and apply the GlossDef paragraph format to the popup window glossary definition.
c. Insert your cursor after the period in the last sentence of the content you want to display in the popup window.
d. On the Special menu, click Marker.
e. In the Marker Type field, select PopupEnd from the drop-down list.
f. Click New Marker. Do not specify any text in the Marker Text field when you insert the marker.
g. In Document Manager, open the Creating Popup Windows.fm file.
h. In the Creating Your First Popup Window (FrameMaker) section in the Creating Popup Windows.fm file, highlight the term popup window in the following sentence:
A popup window can be used to display glossary terms and definitions.
i. On the Special menu, click Cross Reference.
j. In the Document field, select Quick Reference.fm.
k. In the Paragraph Tags field, click GlossTerm.
l. In the Paragraphs field, click Popup windows.
m. In the Format field, select Glossary Term.
n. Click OK.
o. Save your FrameMaker source document.
p. In ePublisher Express, on the Project menu, select the WebWorks Help - Exploring ePublisher target next to Active Target.
q. On the Project menu, click Generate All.
r. In Document Manager, select the Exploring ePublisher top-level group.
s. In Output Explorer, under Navigation, double-click the index.html file to open your generated WebWorks Help output.
t. On the Contents tab, click Popup Windows (FrameMaker) > Creating Your First Popup Window (FrameMaker).
u. Hover over the link and verify that a popup window with the popup window glossary definition you specified displays correctly.
2. Create an expand/collapse section by completing the following steps:
a. In Document Manager, open the Creating Expand Collapse Sections.fm file.
b. In the Creating Your First Expand/Collapse Section (FrameMaker) section, apply the ExpandCollapse paragraph format to the following text:
To create your first expand/collapse section
c. Insert your cursor after the period in the last sentence of the procedure.
d. On the Special menu, click Marker.
e. In the Marker Type field, select DropDownEnd from the drop-down list.
f. Click New Marker. Do not specify any text in the Marker Text field when you insert the marker.
g. Save the Adobe FrameMaker source document.
h. In ePublisher Express, on the Project menu, select the WebWorks Help - Exploring ePublisher target next to Active Target.
i. On the Project menu, click Generate All.
j. In Document Manager, select the Exploring ePublisher top-level group.
k. In Output Explorer, under Navigation, double-click the index.html file to open your generated WebWorks Help output.
l. On the Contents tab, click Expand/Collapse Sections (FrameMaker) > Creating Your First Expand/Collapse Section (FrameMaker).
m. Click on the arrow following the procedure introductory text to expand and display the steps in the procedure.
n. Click on the arrow following the procedure introductory text again to collapse and hide the steps in the procedure.
3. Create related topics links for a topic by completing the following steps:
a. In Document Manager, open the Creating Related Topics.fm file.
b. In the Creating Your First Related Topics Links (FrameMaker) section, apply the RelatedTopic paragraph format to the following list of cross-references at the end of the topic:
*Creating Your First Popup Window (FrameMaker)
*Creating Your First Expand/Collapse Section (FrameMaker)
c. Save the Adobe FrameMaker source document.
d. In ePublisher Express, on the Project menu, select the WebWorks Help - Exploring ePublisher target next to Active Target.
e. On the Project menu, click Generate All.
f. In Document Manager, select the Exploring ePublisher top-level group.
g. In Output Explorer, under Navigation, double-click the index.html file to open your generated WebWorks Help output.
h. On the Contents tab, click Related Topics Links (FrameMaker) > Creating Your First Related Topics Links (FrameMaker).
i. Click on the Related Topics button at the bottom of the page and verify that the list of related topics displays in the generated output.
4. Create a context-sensitive help topic by completing the following steps:
a. In Document Manager, open the Creating Context Sensitive Topics.fm file.
b. In the Creating Your First Context-Sensitive Help Topics (FrameMaker) section, insert your cursor in front of the first paragraph in the topic.
c. On the Special menu, click Marker.
d. In the Marker Type field, select TopicAlias from the drop-down list.
e. In the Marker Text field, specify the following topic ID for the topic:
IDH_CreatingYourFirstContextSensitiveHelpTopicFrame
f. Click New Marker.
g. Save the Adobe FrameMaker source document.
h. On the Project menu, select the Microsoft HTML Help - Exploring ePublisher target next to Active Target.
i. On the Project menu, click Generate All.
j. On the View menu, click Output Directory.
k. In the Exploring ePublisher folder, open the Exploring ePublisher.h mapping file in Notepad.
l. Verify that the IDH_CreatingYourFirstContextSensitiveHelpTopicFrame topic ID is listed in the Exploring ePublisher.h mapping file.