Preparing Microsoft Word Source Documents : Specifying Output File Names in Word : Specifying Page Output File Names in Word : Specifying Image Output File Names in Word
 
Specifying Image Output File Names in Word
Specify specific names for image output files when you generate output if you embed, or insert images directly into the source document instead of inserting and linking or linking images.
Many writers do not need use Filename markers to specify image output file names because many writers prefer to insert images in Microsoft Word source documents as references, or links, using the Link to File or Insert and Link option in the Insert Picture window in Microsoft Word. When writers use one of these methods to insert images, ePublisher automatically uses the name of the image file referenced by the link as the name of the image output file when generating image output files from Microsoft Word source documents.
However, some writers prefer to insert images directly into Microsoft Word source documents using the Insert option in Microsoft Word. If you use the Insert option, Microsoft Word inserts the image directly into the Microsoft Word source document. When you use the Insert option to insert images directly into Microsoft Word source documents, by default, ePublisher assigns image output file names for the inserted images using an image naming pattern. For more information about image naming patterns, see “Specifying Page, Image, and Table File Naming Patterns”.
However, if you use the Insert option to insert images directly into Microsoft Word source documents, you can also use Filename markers to specify image output file names. Insert Filename markers into your source document for each image you want to specify a file name for when you generate content. To specify a file name for an image output file, your Stationery must have the Filename marker type configured. Your output format must also support this feature. For more information about output formats that support this feature, see “Features Available in Each Output Format”.
When you specify image output file names, you create a text box, insert a Filename marker in the text box, and then group the image and the text box that contains the Filename marker. The following procedure provides an example of how to specify image output file names in Microsoft Word source documents using Microsoft Word 2003. Steps for specifying image output file names in Microsoft Word may be different in other versions of Microsoft Word.
To specify image output file names for inserted images in a Microsoft Word source document
1. In your Microsoft Word source document, locate the inserted image for which you want to assign an output image file name.
Note: Only perform this procedure if you have inserted the image directory into the file using the Insert option when you inserted the image into your Microsoft Word source document. Do not perform this procedure if you have inserted the image using the Link to File or Insert and Link options when you inserted the image into your Microsoft Word source document.
2. Right-click the image, and then select Format Picture or Format Object.
3. Change the layout setting of the image to Top and Bottom by completing the following steps:
Note: By default when you insert images into Microsoft Word, Microsoft Word inserts the image using the Inline with text layout setting. In order to specify an image output file name for an inserted image, you must group the image and the text box that contains the Filename marker. However, you cannot group images using the In line with text layout setting in Microsoft Word. To work around this known Microsoft Word issue, if you have an image that uses an In line with text layout setting, use the Top and Bottom layout setting for the image while you insert the Filename marker, and then reapply the Inline with text layout setting after you group the image and the Filename marker.
a. On the Layout tab, click Advanced.
b. On the Text Wrapping tab, click Top and Bottom.
c. Click OK, and then click OK again to close the window.
4. Select the image.
5. On the Insert menu, click Text Box, and then click to the right of your image. Microsoft Word inserts a text box.
6. Insert your cursor into the text box, and then complete the following steps:
a. On the WebWorks menu, click Insert Filename Marker.
b. In the Filename field, type the file name you want to specify for the output image file, and then click OK. ePublisher inserts a Filename marker into the text box.
c. Select the text box.
d. Right-click the selected text box, and then click Format Text Box.
e. On the Colors and Lines tab, the Fill area, in the Color field, select No Fill.
f. In the Line area, in the Color field, select No Line.
g. Click OK.
7. Drag and drop the text box onto the image.
8. Select the text box and the image.
9. Right-click the selected text box and image, and then click Grouping  > Group.
Note: When you select Group, the location of the image in your Microsoft Word source document may change in relation to the text in your source document. For example, the image may move up or down in your Microsoft Word source document. This is known Microsoft Word behavior. You may need to scroll up or down in your source document to the new location of the image to find the image.
10. If your image previously used the In line with text layout setting for the image, reassign this style to the image by completing the following steps:
a. Right-click only the image, and then click Format Object.
Note: You must ensure you right-click only the image, and not on the text box or the grouped text box and image. If you right-click on the text box or the grouped text box and image, Microsoft Word does not display the Format Object menu option on the context menu.
b. On the Layout tab, click In line with text.
c. Click OK, and then click OK again to close the window.
11. Save your Microsoft Word source document.
12. Generate output for your project. For more information, see “Generating Output”.
13. In Output Explorer, verify ePublisher created an image output file using the file name you specified in the Filename marker. For more information, see “Viewing Output in Output Explorer”.