
Automap 9.0 FAQ

External
Last Modified: November 22, 2005

WebWorks Automap

The purpose of this article is to outline key information necessary for 
you to start using WebWorks Automap efficiently. You may expect full 
documentation to be provided with the product in the future. 

Scripting

Which script variables are available at the various stages?

Variable
Project 

PreBuild/
PostBuild

Target 
PreBuild/
PostBuild

Group 
document 
retrieval

JobDir X X Xa

JobFile X X Xa

ProjectDir X X Xa

ProjectFile X X Xa

JobName X X X

BuildAction X X X

TargetDeployKey X

ErrorCount X

TargetName X

TargetOutputDir X

DeployFolder X

GroupName X

FileListName X

FileListPath X

a. Not available when scanning documents in Job Wizard



How does the document retrieval script work when assigned to a 
group?
The text that is entered into the script editor is saved into a batch file and 
executed.  If the script returns successfully, WebWorks AutoMap will look for a 
text file at the location specified by the variable “FileListPath” which should 
contain a line delimited list of documents the user would like to add to the 
group.

Why are certain variables not available when scanning documents in the 
Job Wizard or Job Editor?
During the job creation process, the “JobDir” and “JobFile” are not available 
because the job has not been saved yet., and the “ProjectDir” and 
“ProjectFile” variables are not available because a WebWorks ePublisher Pro 
project does not exist yet.  They are only available during generation.

What is the current working directory when a script executes?
During generation the current working directory is set to the location of the job 
file’s directory.

When scanning documents in the Job Editor, the current working directory is 
the job file’s directory.

When scanning documents in the JobWizard, the current working directory is 
the location of the temporary script file.

Why does the hierarchy under a group get ignored, when a script is 
assigned to it?
WebWorks AutoMap will ignore the hierarchy because there currently is no 
way to specify the location of the documents retrieved by the script.  A 
workaround is to create adjacent groups and place them before or after the 
group that has a script assigned to it.

Command-Line

Which command-line switches are valid when processing a WebWorks 
AutoMap job file versus a WebWorks ePublisher Pro project?

WebWorks AutoMap 
job (.waj)

WebWorks ePublisher 
Pro Project (.wep)

  -f, --nonotify X

 -s, --stagingdir X

-u, --userformats X X

-t, --target X

  -n, --nodeploy X X

 -c, --clean X

  -l, --cleandeploy X



Deployment

Why does WebWorks AutoMap report “Deployment failed. Can not find 
the deploy setting in preferences” even though it exists in WebWorks 
ePublisher Pro preferences?
Currently WebWorks AutoMap does not share preferences with WebWorks 
ePublisher Pro, so it is necessary to create deploy settings in WebWorks 
AutoMap that have the same names.

Formats

Why does WebWorks AutoMap reports that it can not load the custom 
user format when it is trying to generate?
By default WebWorks AutoMap and WebWorks ePublisher Pro both look in 
the same location for user formats.  Verify that in the WebWorks AutoMap 
application preferences that the “User Format Directory” is pointing to the 
directory that contains the user format.  If the command line interface is being 
used, the user format directory can be specified by using the “-u” or “--
userformats” switches.

Administrator

Why does the job fail to generate when the job is run directly from the 
Administrator?
The Administrator uses the Windows Task Scheduler to schedule the job.  It is 
recommended that the user specifies the username and password of their 
account when the “User Information” dialog is displayed.

Preferences

Why are the “File Mapping” and “Deploy Locations” preferences not 
shared between WebWorks AutoMap and WebWorks ePublisher Pro?
At this time, the preferences between both products are separate, however 
the user can copy the preferences if they wish to do so.

 For file mappings, copy the file at:

C:\Documents and Settings\<username>\Local Settings\Application 
Data\WebWorks\ePublisherPro\9.0\filemapping.prefs



to

C:\Documents and Settings\<username>\Local Settings\Application 
Data\WebWorks\Automap\9.0\filemapping.prefs

For deployment locations, copy the file at:

C:\Documents and Settings\<username>\Local Settings\Application 
Data\WebWorks\ePublisherPro\9.0\deploy.prefs

to

C:\Documents and Settings\<username>\Local Settings\Application 
Data\WebWorks\Automap\9.0\deploy.prefs
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ePublisher Pro

The purpose of this article is to explain how to add copyright information to the 
bottom of output pages.

In order to add copyright information to the bottom of output pages, you will need to 
modify Page.asp.

Please see Creating Project Target Overrides for more information on how to create a 
project target override. 

Modifying Page.asp
1) Create a project target override on Page.asp.

Note:By default, Page.asp is located in C:\Program Files\WebWorks\ePublisher Pro\For-
mats\[FORMAT]\Pages, where [FORMAT] is the name of the format from which the target 
to be generated is based.

2) Open Page.asp in the text editor of your choice.

3) Place your cursor just before the closing </body> tag.

4) Add the following line of code just before </body>
<div style="font-size: 8pt; font-family: verdana; font-weight: bold; text-
align: center;">Copyright &#169; 2006 Quadralay Corporation.</div>

So it should look something like this:

</script>

<div style="font-size: 8pt; font-family: verdana; font-weight: bold; 
text-align: center;">Copyright &#169; 2006 Quadralay Corporation.</
div>

</body>

</html>

Note:You can add any CSS style information you would like for the style attribute. In this 
example, we have set the font to 8pt, verdana, bold, and aligned center.

5) Save and close the file.

6) Regenerate your project.

Note:If you receive an error such as [Error] An error occurred in 'LoadXMLWithoutRe-
solver' while loading '[FILE_PATH]\Formats\WebWorks Help 5.0\Pages\Page.asp', you 
have entered invalid HTML or have tried to use XML replacements and conditions. Make 
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The purpose of this article is to provide users with a troubleshooting procedures 
that have previously resolved the 3 common Word errors below. 

"Cannot duplicate document '[docname.doc]' to '[path]\preview.docwif' and apply settings."

“Unable to create WIF document.”

“Adapter "Word" failed in method "GenerateXML" at step "2: Word.GenerateXML".”

These are general errors that are being thrown for one of two reasons: either 
ePublisher cannot communicate with Word or there is something corrupt in the source 
document (.doc) or source document template (.dot).

Before you begin troubleshooting
1) Take note of the results as you go through the following steps, so that our support team 

can help you isolate the problem if you are not able to resolve it using these 
techniques.

2) Make sure all files and applications are on a local hard drive (C:) before testing, and 
not in a shared location.

3) We recommend that before making any of the changes suggested below to your 
system setup, that first, you close Microsoft Word, Outlook and WebWorks ePublisher, 
and verify that no WINWORD.EXE processes are running.

Note:To verify that none of these processes are still running, use the (Ctrl+Alt+Delete) 
shortkey command to open the Task Manager. Verify that the Processes tab is selected, 
and if you see any processes that say WINWORD.EXE or wpubword.exe, select them and 
choose End Process.

Troubleshooting
1) Are you using a custom template?

If you are using a custom template, often Word can embed references to missing paths to the template. To 
verify, open the source document that is causing these problems. Go to Tools > Macro > Visual Basic 
Editor and then go to Tools > References. There should be a list of Available References starting with 
the references that are checked. If you see a reference that is checked and says “Missing” in front of it, 
uncheck this reference and then save and close Word.

2) Do you encounter this error on all documents consistently? 
If not, there is something in your documents that is causing the crash and you will need to open a support case 
with the entire ePublisher project directory as well as a reduced version of the source document and custom 
template (if applicable) that will recreate the issue. In addition, please be prepared to answer the questions 
listed in this article.



3) Do you have any third party plug-ins such as SnagIt? 
Earlier versions of SnagIt that are older than SnagIt 8 have caused problems in ePublisher in the past. There 
are currently no known issues with SnagIt 8. If you are using earlier versions than SnagIt 8, you will need to 
disable these in Word.

To disable SnagIt 7, you will need to uninstall SnagIt and then reinstall. When you reinstall, you will be 
asked to specify what features of SnagIt you want to install. Be sure when you get to this step to disable the 
SnagIt Add-In for Word as illustrated in the screen capture below. 

Disabling SnagIt 7 Word Add-In

To disable SnagIt 6, close all instances of Word and then open SnagIt. Go to Tools > Program 
Preferences > Addins and then disable the Word Add-In.

4) Do you have anti-virus software?
Due to limitations in McAfee, Norton Anti-Virus and Norton SystemWorks, you may encounter problems 
when attempting to create and generate output from a WebWorks ePublisher project if you are running one of 
these products on your machine.

If you are running Norton Antivirus, make sure that you have scripting enabled, Norton has a script-blocking 
feature that prevents WebWorks Publisher from making some necessary calls to the system.

First, close all other applications (especially Outlook or other e-mail software), and ensure that no 
WINWORD processes are running, see Step 3 in "Before you Begin Troubleshooting". Then close Norton 
Anti-Virus or Norton SystemWorks, and try creating your project or generating your output. If closing the 
Norton product does not resolve the problem, we recommend you implement the workaround described in the 
following Microsoft KnowledgeBase article:

http://support.microsoft.com/default.aspx?scid=kb;EN-US;q243579 

5) What are your macro settings in Word? 
Check the Macro security in Word (Tools -> Macros -> Security). If the Security Settings are set to High or 

http://support.microsoft.com/default.aspx?scid=kb;EN-US;q243579


Very High, try changing them to Medium. Before doing this, please be sure that you have ended all 
WINWORD processes, see Step 3 in "Before you Begin Troubleshooting", otherwise the security settings 
change may not take effect. Then, try creating a project again.

6) Are you using a Network or shared drive?
Often users who have their files located on a network or shared drive will encounter these errors. Users may be 
able to modify these files over a network drive; however, ePublisher accesses these files differently and 
depending on how your system administrator setup your security settings, you may not have sufficient 
privileges to access these files from a program like ePublisher even though you have access to modify the files 
directly. To verify, create a project on your local C: and add documents that are also located on your local C:. If 
you are then able to generate properly, you will need to get with your system administrator to setup the 
appropriate security settings.

7) Check the read/write permissions on the source files?
It never hurts to check to make sure the source files were not set to Read Only. Double check by right-clicking 
on your source document and verify that you have read/write access privileges to the file. 
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The purpose of this article is to explain how to disable external CSS files from 
being generated. 

For each document in your ePublisher Pro project, an external CSS file is created. The 
number of files in the project and the amount of style information in each document 
determines the size of these CSS files; they can become very large and redundant. 
Often, custom CSS files are used to get around this; however, ePublisher Pro will still 
emit the external CSS files. Often users will just delete the unused CSS files but this 
can be problematic if they are deploying straight to a web server. 

We will look at how to modify pages.fti and styles.xsl files to allow users to choose 
whether or not they want to emit the external CSS files. You will need to be familiar 
with how to perform a project target override. For more information on how to 
perform a project target override, please see “Creating Project Target Overrides”.

Modifying pages.fti
Modifying the pages.fti file allows users to place an option setting in the UI that will 
allow users to enable or disable CSS file generation.

1) Perform a project target override on the file pages.fti.

Note:By default pages.fti is located in C:\Program Files\WebWorks\ePublisher Pro\For-
mats\[FORMAT]\Transforms where [FORMAT] is the format from which the target you are 
converting is based.

2) Open pages.fti and find the <Groups> tag.  Add the following:
<Group name="css" />

So the modified section would look like this:

<Groups>

<Group name="css" />

<Group name="files" />

<Group name="toc" />

<Group name="accessibility" />

<Group name="pdf" />

<Group name="options" />

<Group name="navigation" />



</Groups>

3) Under the <Settings> tag add the following:
<!-- Emit external CSS -->

<!--                   -->

<Setting name="emit-external-css" group="css" default="true">

<SettingClass name="boolean" />

</Setting>

So the modified section would look like this:

<Settings>

<!-- Emit external CSS -->

<!--                   -->

<Setting name="Emit External CSS" group="CSS" default="true">

<SettingClass name="boolean" />

</Setting>

<!-- Encoding -->

<!--          -->

4) Save and close this file.

Modifying styles.xsl
Modifying the code in styles.xsl will check the option setting from the pages.fti file 
and will determine based on the setting whether or not to emit the CSS files.

1) Perform a project target override on the file styles.xsl.

Note:By default styles.xsl is located in C:\Program Files\WebWorks\ePublisher Pro\For-
mats\[FORMAT]\Transforms where [FORMAT] is the format from which the target you are 
converting is based.

2) Open styles.xsl and find the <wwfiles:Files version="1.0"> tag. Add the following:
<xsl:if test="wwprojext:GetFormatSetting('emit-external-css', 'false') = 
'true'">

So the modified section would look like this:

<wwfiles:Files version="1.0">

<xsl:if test="wwprojext:GetFormatSetting('emit-external-css', 'false') = 
'true'">

<!-- Groups -->

<!--        -->

3) Under the <xsl:variable name="VarProgressProjectGroupsEnd" 
select="wwprogress:End()" /> tag add the following:
</xsl:if>

So the modified section would look like this:

<xsl:variable name="VarProgressProjectGroupEnd" select="wwprogress:End()" 
/>

</xsl:for-each>



<xsl:variable name="VarProgressProjectGroupsEnd" 
select="wwprogress:End()" />

</xsl:if>

</wwfiles:Files>

</xsl:template>

4) Save and close this file.

Format Settings
1) If your ePublisher Pro project is open, save and close the project and then reopen it.

2) Go to Format > Format Settings and next to the new heading emit-external-css set the 
value to Disabled.

3) Regenerate All (Ctrl+Shift+F5).
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The purpose of this article is to explain how to control the name of the output files 
generated by ePublisher Pro by using filename markers.

Filename markers allow you to control the names of your output files. By default, 
ePublisher Pro will generate output file names based on the name of the source 
document. In order to specify names for your output files, you need to insert filename 
markers into the headings in your source document that have page splits applied. Once 
you have embedded filename markers into your source documents, you need to assign 
filename marker behavior to the filename markers. The following steps will walk you 
through embedding filename markers into Adobe FrameMaker or Microsoft Word 
documents and setting up the correct filename marker behavior in ePublisher Pro.

Using filename markers with Adobe FrameMaker:
1) In your FrameMaker document, go to Special > Marker. 

2) From the Marker Type drop-down, choose Edit.

3) Type in Filename; this will be the name of the custom marker. 

4) Click Add.

5) Locate the heading that starts the new page whose filename you want to assign.

6) Within that heading, insert a Filename marker. 

7) For the marker text of the filename marker, type in the name you want to assign to the 
output file (without the file extension).

8) Save your FrameMaker document.

9) In ePublisher Pro, go to Project > Scan All Documents to pick up any new marker style 
information from your source documents.

10) Go to View > Style Designer.

11) Click on the Marker Styles tab.

12) Select Filename from the list of marker styles.

13) Choose Filename for the value of the marker type.

14) Close the Style Designer.

15) Go to Project > Regenerate All to generate your project.

Using filename markers with Microsoft Word:
1) In your Word document, locate the heading that starts the new page whose filename 

you want to assign.



2) Go to WebWorks > Markers.

3) Select Filename from the list of markers.

4) For the filename value, type in the name you want to assign to the output file.

5) Click Apply or OK to insert the filename marker.

6) Save your Word document.

7) In ePublisher Pro, go to Project > Scan All Documents to pick up any new marker style 
information from your source documents.

8) Go to View > Style Designer.

9) Click on the Marker Styles tab.

10) Select Filename from the list of marker styles.

11) Choose Filename for the value of the marker type.

12) Close the Style Designer.

13) Go to Project > Regenerate All to generate your project.
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The purpose of this article is to explain how to install the .Net Framework if the 
following error message appears when trying to install WebWorks ePublisher 
Pro.

Installing the Microsoft.NET 2.0 Framework
1) When you receive the error message above click Yes.

2) You will then be directed to the Microsoft .Net website. 



3) Click on Download under the On this Page heading as shown in the image above.

4) Click on Open or Save. 

Note:If you select Save this will allow you to save dotnetfx.exe file. 

5) When Open or Save finish click Open and start installing Microsoft.NET 2.0

6) Once installation of Microsoft.NET 2.0 is complete, you can then install WebWorks 
ePublisher Pro.
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The purpose of this article is to explain how to properly link to PDFs in 
FrameMaker and Word documents and have them open in a new window.

This article will go over the proper way to link to PDFs in ePublisher. In addition, this 
article will also go over how to modify content.xsl to have your PDFs open in a new 
window. 

In FrameMaker
In order to create a link to a PDF file from WebWorks Help, you will need to first 
create a link to a PDF in your FrameMaker document. To achieve this, create a 
hypertext marker within your selected text area (where you would like to create your 
link).

1) In the FrameMaker menu, go to Special > Hypertext (This will open the Hypertext 
box.) 

2) From the Command dropdown menu, choose Message Client. 
3) In the Syntax text box, type message openfile relative_path. 

Example: 

message openfile Testing/Sample.pdf

Note:Before generating your project in ePublisher, you can test your link in FrameMaker 
by using the shortcut Ctrl + Alt and click your link. If your links in FrameMaker are done 
correctly, they should generate properly in WebWorks ePublisher. 

4) Save and close the file.

5) Regenerate the project.

In Word
1) In the Word menu, go to Insert > Hyperlink.

2) Select “Existing File or Web Page” for the “Link to” property.

3) In the “Text to display” option, type in the text you want to display for the link.

4) Navigate and select the PDF file and click OK.

Note:Before generating your project in ePublisher, you can test your link in Word by using 
the shortcut selecting Ctrl + click to follow your link. If your links in Word are done cor-
rectly, they should generate properly in WebWorks ePublisher. 

5) Save and close the file.



6) Regenerate the project.

Setting PDFs to Open in a New Window
New to ePublisher Pro 9.2, you can now specify in the UI how your external links will 
be launched.  By default, PDF links will open in a separate browser window.  In the 
Format Settings dialog, you can also choose to open external/baggage files in the 
current topic frame
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The purpose of this aricle is to explain how to modify the content of the TOC 
page when using the XML+XSL format.

If you are using the the XML+XSL format for your online help and you want to 
change the formatting of the content on the TOC page (e.g. changing the font of the 
TOC entries), then you must perform a target override on and modify the 
“document.xsl” file.

Troubleshooting Steps
The first part is to create a target override on the document.xsl file, which is located in 
the installation directory. Be default the installation directory is located at C:\Program 
Files\WebWorks\ePublisher Pro\Formats\XML+XSL\Files\xsl.  For more information 
on creating target overrides read “Creating Project Target Overrides”.  Once you have 
created your target override on document.xsl, you may modify this file to affect the 
formatting of the content of the TOC.  The following steps represent only a simple 
example demonstrating how you can extend the capabilities of  ePublisher Pro.

1) Right-click on document.xsl and open it in your preferred text editor.

2) Search for the string def-data.

3) Find the following line of code:
<xsl:template match=”*[@wp:type = ‘def-data’]”>

4) Look for the <dd> tag directly beneath the above line of code.

5) In this <dd> tag you will add a style attribute.  This will change the style of the TOC 
page.
Example:  <dd style=”font-family: Arial”>

6) Save and close document.xsl.

7) Regenerate your ePublisher Pro project. Select Project > Regenerate All.

You will now see that the content of the TOC page in the XML+XSL format output 
has been changed to the style that you added to the <dd> tag in the document.xsl file.
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The purpose of this article is to provide an example of how to modify the 
appearance of bullets. 

At this time, ePublisher Pro does not support structured lists due to CSS limitations. 
This article will show you how to replace bullets from your source document and 
modify their appearance. The following method is also useful on how to replace a 
bullet if you have a dingbat or symbol bullet that does not appear correctly in your 
browser.

Modifying the appearance of bullets:
1) In ePublisher Pro, select View > Style Designer.
2) Click on the Paragraph Styles tab.

3) Select the paragraph style that your bulleted list uses.

4) Click on the Properties tab. 

5) Select the Bullet property.

6) In the text field place a bullet character • . 

Note:This will remove any dingbat or symbol font issues. You can also place a space or 
any other text here and ePublisher will replace the bullet from the source document with 
whatever you place in the text field. You can get a bullet character from Word or simply 
copy and paste the one in this article.

7) Click on the Character Styles tab.

8) Click on the New Style button in the upper left hand corner.

9) Name the new style something like MyBullet.

10) Click on the Properties tab and modify any properties. 

Example: 

Click on the Font property and set the width to 20pt. 

Click on the Text property and set the Color to Red.

11) Click on the Paragraph Styles tab.

12) Select the paragraph style that your bulleted list uses.

13) Click on the Bullet property.

14) Set the Character Style to MyBullet. 

15) Close the Style Designer.



16) Select Project > Regenerate All.
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The purpose of this article is to provide an example on how to modify the 
appearance of popups.

Once you have successfully created popups, you are now ready to modify the 
appearance of your popups. For more information on creating popups, please see our 
“Creating Popups” knowledge base article. 

As discussed in the “Creating Popups” knowledge base article, there are two methods 
you can use to create popups: using markers and using paragraph styles. This article 
will provide an example on how to modify the appearance of popups for either 
method. If you used markers to create your popups, please see “Modifying popups 
created with markers”. If you used paragraph style to create your popups, please see 
“Modifying popups created with paragraph styles”.

Modifying popups created with markers
1) Go to View > Style Designer.

2) Click on the Page Styles tab.

3) Click on the Add New Style button to create a new page style for your popups.

4) Give the new page style a name.

Note:This step is very important. The name you specify here should be the same as the 
name you specified for the popup marker in your source document. So for example, from 
the "Creating Popups" knowledge base article, you may have named this page style 
Popup_Page_Style.

5) Make modifications to the new page style. See below for an example.

• Click on the Properties tab.
• Select the Margins property.
• Set all the Margins to 0px.
• Select the Padding property.
• Set all Padding to 0px.
• Click on the Options tab.
• Set Breadcrumbs shown at top of page to Disabled.
• Set Navigation links shown at top of page to Disabled.

6) Click on the Paragraph Styles tab.

7) Select the paragraph style associated with the popup text.

8) Click on the Properties tab.

9) Make modifications to the paragraph style. See below for an example.



• Click on the HTML property.
• Set the Width of the popup block to 250px.

10) Close the Style Designer and type Ctrl+Shift+F5 to regenerate your project.

Modifying popups created with paragraph styles
1) Go to View > Style Designer.

2) Click on the Page Styles tab.

3) Click on the Add New Style button to create a new page style for your popups.

4) Give the new page style a name.

5) Make modifications to the new page style. See below for an example.

• Click on the Properties tab.
• Select the Margins property.
• Set all the Margins to 0px.
• Select the Padding property.
• Set all Padding to 0px.
• Click on the Options tab.
• Set Breadcrumbs shown at top of page to Disabled.
• Set Navigation links shown at top of page to Disabled.

6) Click on the Paragraph Styles tab.

7) Select the paragraph style you used to create your popups.

8) Click on the Properties tab.

9) Make modifications to the paragraph style. See below for an example.

• Click on the HTML property.
• Set the Width of the popup block to 250px.

10) Click on the Options tab.

11) For the Popup page style select the name of your popup page style.

12) Close the Style Designer and type Ctrl+Shift+F5 to regenerate your project.
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The purpose of this article is to provide an example of how to create  popups. 

In order to create popups, you first must create hyperlinks from the popup topic to the 
popup text. The popup topic is the term or phrase that the user hovers over in order to 
get the popup window; the popup text is the content that is contained within the popup 
window. 

After you have created hyperlinks, there are two methods for creating the actual 
popup. One way is to utilize markers to define the content contained within the popup 
window. The other method, which user’s may find more convenient, is to utilize 
paragraph styles that are associated with a popup behavior. The major difference is 
time. Using markers allows for backward compatiablity with our previous products 
and more control, however it is much more time consuming to place markers in your 
document than to simply apply a paragraph style.

Once you have successfully created your popups, you can modify the appearance of 
your popups. Please see “Modifying the Appearance of Popups” for more information.

The following sections will walk you through creating popups:

Creating Popups with Markers For Adobe FrameMaker

Creating Popups with Markers For Microsoft Word

Creating Popups with Paragraph Styles For Adobe FrameMaker

Creating Popups with Paragraph Styles For Microsoft Word

Creating Popups with Markers

For Adobe FrameMaker
1) In your source document, create a hyperlink from the popup topic to the popup 

text.

2) Go to Special > Marker.

3) From the drop-down list of Marker Types, choose Edit.

4) Name the marker Popup.



5) Click the Add button.

6) Create a second marker and name it PopupEnd.

7) Locate the starting point for the popup text.

8) Insert the Popup marker.

Note:If you want to modify the appearance of your popup, type the name of the page 
style you will associate with your popups (i.e. Popup_Page_Style) for the Marker Text.

9) Locate the ending point for the popup text.

10) Insert the PopupEnd marker.

11) Save the FrameMaker document.

12) In WebWorks ePublisher Pro, select the top-level group in the Document Manager.

13) Press Ctrl + F7 to scan the source documents for new style information.

14) Press F10 to open the Style Designer.

15) Click on the Marker Styles tab.

16) Select the Popup marker and select one of the following behaviors:

• Choose Popup start if you want your popup text to appear in a window and 
through a clickable link that redirects users to the actual location of the popup text 
(i.e. a Glossary).

• Choose Popup start with no output if you only want the popup text to appear in 
a window.

17) Select the PopupEnd marker and select the Popup end behavior.

18) Press Ctrl + F5 to generate the project.

For Microsoft Word
1) In your source document, create a hyperlink from the popup topic to the popup 

text. Do this by inserting a bookmark at the popup text and creating a hyperlink 
from the popup topic to the bookmark.

2) After you have created the hyperlink, place the insertion point at the beginning of 
the popup text.

3) Go to WebWorks > Markers.

4) Select Popup or PopupOnly from the list of markers.

• Choose Popup if you want your popup text to appear in a window and through a 
clickable link that redirects users to the actual location of the popup text (i.e. a 
Glossary).

• Choose PopupOnly if you only want the popup text to appear in a window.



5) Click OK to insert the popup marker.

Note:If you want to modify the appearance of your popup, type the name of the page 
style you will associate with your popups (i.e. Popup_Page_Style) for the Value.

6) Place the insertion point where the popup text ends.

7) Go to WebWorks > Markers.

8) Select PopupEnd.

9) Save the Word document.

10) In WebWorks ePublisher Pro, select the top-level group in the Document Manager.

11) Press Ctrl + F7 to scan the source documents for new style information.

12) Press Ctrl + F5 to generate the project.

Creating Popups with Paragraph Styles

For Adobe FrameMaker
1) In your source document, create a hyperlink from the popup topic to the popup 

text.

2) Apply any paragraph style to the popup text (i.e. PopupStyle). 

3) Save the FrameMaker document.

4) In WebWorks ePublisher Pro, select the top-level group in the Document Manager.

5) In WebWorks ePublisher Pro, press Ctrl + F7 to scan the source documents for 
new style information.

6) Go to View > Style Designer.

7) Click on the Paragraph Styles tab.

8) Select the paragraph style you used for the popup text.

9) Click on the options tab.

10) Choose the behavior you want for your popups by choosing the appropriate option 
for the paragraph style. There are two items that will dictate which option you will 
choose for this paragraph style:

1) How the user would like the popup to be displayed. 

•     Popup window only
•     Popup window and through a clickable link

2) How many paragraphs the popup will contain.

•     Single paragraph.



•    Multiple paragraphs.

This defines four scenarios:
1) Popup Window Only with a single paragraph.

• Choose Define no output for the paragraph to be displayed in the popup win-
dow.

2) Popup Window only with multiple paragraphs.

• Choose Define no output for the first paragraph to be displayed in the popup 
window.

• Choose Append no output for all following paragraphs.

3) Popup Window and clickable link with a single paragraph.

• Choose Define for the paragraph that will be displayed in the window. This is 
the same paragraph that will appear on the HTML page to which the link will 
redirect.

4) Popup Window and clickable link with multiple paragraphs.

• Choose Define for the first paragraph that will be displayed in the window. 
This is the same paragraph that will appear on the HTML page to which the 
link will redirect.

• Then choose Append for all following paragraphs.

5) Close the Style Designer and press Ctrl + F5 to generate the project.

For Microsoft Word
1) In your source document, create a hyperlink from the popup topic to the popup 

text. Do this by inserting a bookmark at the popup text and creating a hyperlink 
from the popup topic to the bookmark.

2) Apply any paragraph style to the popup text (i.e. PopupStyle). 

3) Save the Word document.

4) In WebWorks ePublisher Pro, press Ctrl + F7 to scan the source documents for 
new style information.

5) Go to View > Style Designer.

6) Click on the Paragraph Styles tab.

7) Select the paragraph style you used for the popup text.

8) Click on the options tab.

9) Choose the behavior you want for your popups by choosing the appropriate option 
for the paragraph style. There are two items that will dictate which option you will 
choose for this paragraph style:

1) How the user would like the popup to be displayed. 



•     Popup window only
•     Popup window and through a clickable link

2) How many paragraphs the popup will contain.

•     Single paragraph.
•    Multiple paragraphs.

This defines four scenarios:
1) Popup Window Only with a single paragraph.

• Choose Define no output for the paragraph to be displayed in the popup win-
dow.

2) Popup Window only with multiple paragraphs.

• Choose Define no output for the first paragraph to be displayed in the popup 
window.

• Choose Append no output for all following paragraphs.

3) Popup Window and clickable link with a single paragraph.

• Choose Define for the paragraph that will be displayed in the window. This is 
the same paragraph that will appear on the HTML page to which the link will 
redirect.

4) Popup Window and clickable link with multiple paragraphs.

• Choose Define for the first paragraph that will be displayed in the window. 
This is the same paragraph that will appear on the HTML page to which the 
link will redirect.

• Then choose Append for all following paragraphs.

5) Close the Style Designer and press Ctrl + F5 to generate the project.



ePublisher Equivalent Format Settings in Publisher 2003
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ePublisher Pro

The purpose of this article is to explain the ePublisher equivalent format settings 
found in Publisher 2003 project options.

In Publisher 2003, there are many Project Options for each format (Project > Options). 
In ePublisher, these Project Options are known as Format Settings (Format > Format 
Settings).

General Settings for all Formats (Templates)
The following table covers the General Project Option settings found in all the formats 
for Publisher 2003. These general settings include the General tab, Folders tab and 
FrameMaker (FM only) tab in Publisher 2003.

Tab in 2003 Setting in 2003 ePublisher Equivalent

General Generate Pages View > Style Designer > Paragraph 
Styles > Default style > Options > 
Generate Output

 Generate Graphics View > Style Designer > Graphic 
Styles > Options > Generate Output

 Generate 8.3 file names Not Supported

 Use pre-2003 file naming conventions Not Supported

 Use the following file naming rules for 
pages and graphics

Not Supported

 Convert any white space to underscores Not Supported

 Line Endings Not Supported

 Max Buffer Not Supported

 Language Encoding Format > Format Settings > Locale

 Character Encoding Format > Format Settings > 
Encoding

 Project to project linking context Format > Merge Settings > Merge 
Title



WebWorks Help Specific Settings
The following table covers the Project Option settings specifically for WebWorks Help 
in Publisher 2003.

Folders Output Folder Format > Format Settings > 
Encoding > Generated Output 
Location

 Images Folder Not Supported - Done by default

 Support Folder Not Applicable

 Temporary File Folder Not Applicable

 Keep these folders relative to the project 
if it moves

Not Supported - Done by default

 Copy the following files from SUPPORT 
to OUTPUTDIR

View > User Files (place the files 
you want copied over in the Files 
directory)

FrameMaker 
(FrameMaker only)

Automatically remove front matter when 
adding books to this project

Not Supported in GUI - Done by 
default

 Automatically re-order the TOC and IX 
when adding books (legacy)

Not Supported in GUI - TOC and IX 
in FrameMaker are never used

 Automatically remove the TOC and IX 
when adding books (2003 and later)

Not Supported in GUI - Done by 
default

 Map to structure elements rather than 
formats

Not Supported

Tab in 2003 Setting in 2003 ePublisher Equivalent

Tab in 2003 Setting in 2003 ePublisher Equivalent

WebWorks Help Use Java applet for navigation if a 
suitable JRE can be found

The Java applet is no longer 
supported

 Contents Format > Format Settings > 
Generate table of contents

 Index Format > Format Settings > 
Generate index

 Search Format > Format Settings > Show 
search tab

 Favorites (requires Java and cookies) Format > Format Settings > Show 
favorites tab

 Using cookies is OK Format > Format Settings > Use 
browser cookies



 The entry point to this helpset should be 
a file named

Format > Format Settings > Top 
level filename

 Synchronize Contents Format > Format Settings > 
Automatically synchronize the TOC

 Next/Previous Topic Format > Format Settings > Show 
previous & next toolbar buttons

 E-mail Format > Format Settings > 
Company email address

 Print Format > Format Settings > Show 
print toolbar button

 Bookmark Format > Format Settings > Show 
bookmark toolbar button

Context Sensitivity Use Filename markers as topic aliases Not supported

 Preview Implementation Not supported in GUI

Accessibility Ask users the first time they view the 
helpset if they’d like accessibility 
features and remember their 
preferences (requires cookies)

Format > Format Settings > 
WebWorks Help accessibility

 Don’t ask users. If I want the accessible 
version I will specify it in the link to my 
helpset 

Format > Format Settings > 
WebWorks Help accessibility

 Don’t ask users. Always use the 
accessible version

Format > Format Settings > 
WebWorks Help accessibility

 Generate an accessibility report for this 
project after each conversion

Format > Format Settings > 
Generate accessibility report

 Validate that each image has an alt tag Format > Format Settings > 
Validate accessibility image 
alternate tags

 Validate that each image map hotspot 
has an alt tag

Format > Format Settings > 
Validate accessibility image map 
alternate tags

 Validate that each image has a long 
description

Format > Format Settings > 
Validate accessibility image long 
descriptions

 Automatically generate place holder 
long description files

Format > Format Settings > 
Validate accessibility image long 
descriptions

 Include visible [D] links to images that 
have long descriptions

Format > Format Settings > Include 
visible [D] links to images with long 
descriptions

Tab in 2003 Setting in 2003 ePublisher Equivalent



Dynamic HTML Specific Settings
The following table covers the Project Option settings specifically for Dynamic 
HTML in Publisher 2003.

 Validate that each table has a summary Format > Format Settings > 
Validate accessibility table 
summaries

TOC/IX Treat multi-level TOC transitions as Format > Format Settings > 
Collapse table of contents

Tab in 2003 Setting in 2003 ePublisher Equivalent

Tab in 2003 Setting in 2003 ePublisher Equivalent

TOC/IX Generate a Table of Contents file named Format > Format Settings > Table of 
contents file name

 Treat multi-level TOC transitions as Format > Format Settings > Collapse 
table of contents

 Generate an Index file named Format > Format Settings > Generate 
index / Index filename

 Use page titles as link text Not Supported in GUI - Done by default

 Generate a Frameset file named Not Supported

Accessibility Generate an accessibility report for this 
project after each conversion

Format > Format Settings > Generate 
accessibility report

 Validate that each image has an alt tag Format > Format Settings > Validate 
accessibility image alternate tags

 Validate that each image map hotspot 
has an alt tag

Format > Format Settings > Validate 
accessibility image map alternate tags

 Validate that each image has a long 
description

Format > Format Settings > Validate 
accessibility image long descriptions

 Automatically generate place holder 
long description files

Format > Format Settings > Validate 
accessibility image long descriptions

 Include visible [D] links to images that 
have long descriptions

Format > Format Settings > Include 
visible [D] links to images with long 
descriptions

 Validate that each table has a summary Format > Format Settings > Validate 
accessibility table summaries



Microsoft HTML Help Specific Settings
The following table covers the Project Option settings specifically for Microsoft 
HTML Help in Publisher 2003.

Tab in 2003 Setting in 2003 ePublisher Equivalent

HTML Help Title Not supported in GUI - must override 
the template.hhp file

 Compiled File Filename is the value of the Group 
Name as specified in the Document 
Manager

 Install Location Format > Format Settings > HTML 
Help location

 Default Window Not supported in GUI - must override 
the template.hhp file

 Window Definitions Not supported in GUI - must override 
the template.hhp file

 Build a binary index Format > Format Settings > HTML 
Help binary index

Context Sensitivity Automatically generate a map file and 
aliases

Not supported in GUI - Done by 
default

 Use the following map file Format > Format Settings > HTML 
Help custom map file

 Use Filename markers as topic 
aliases

Not Supported

 Test Not supported in GUI - must use 
HTML Help Workshop

TOC/IX Treat multi-level TOC transitions as Format > Format Settings > Collapse 
table of contents

Accessibility Generate an accessibility report for 
this project after each conversion

Format > Format Settings > Generate 
accessibility report

 Validate that each image has an alt 
tag

Format > Format Settings > Validate 
accessibility image alternate tags

 Validate that each image map hotspot 
has an alt tag

Format > Format Settings > Validate 
accessibility image map alternate 
tags

 Validate that each image has a long 
description

Format > Format Settings > Validate 
accessibility image long descriptions

 Automatically generate place holder 
long description files

Format > Format Settings > Validate 
accessibility image long descriptions



Microsoft WinHelp Specific Settings
The following table covers the Project Option settings specifically for Microsoft 
WinHelp in Publisher 2003.

Oracle Help Specific Settings
The following table covers the Project Option settings specifically for Oracle Help in 
Publisher 2003.

 Include visible [D] links to images that 
have long descriptions

Format > Format Settings > Include 
visible [D] links to images with long 
descriptions

 Validate that each table has a 
summary

Format > Format Settings > Validate 
accessibility table summaries

Tab in 2003 Setting in 2003 ePublisher Equivalent

Tab in 2003 Setting in 2003 ePublisher Equivalent

TOC/IX (TOC name field) Format > Format Settings > WinHelp 
title

 Treat multi-level TOC transitions as Format > Format Settings > Collapse 
table of contents

Tab in 2003 Setting in 2003 ePublisher Equivalent

Oracle Help Title Format > Format Settings > Helpset 
title

 JAR File Filename is the value of the Group 
Name as specified in the Document 
Manager

 OHJ install location Format > Format Settings > Oracle 
Help Location

 JDK install location Format > Format Settings > JDK 
location

 Include TOC navigator tab Format > Format Settings > Generate 
table of contents

 Include index navigator tab Format > Format Settings > Generate 
index

 Include search navigator tab Format > Format Settings > Enable 
search tab

TOC/IX Treat multi-level TOC transitions as Format > Format Settings > Collapse 
table of contents



Simple HTML Help Specific Settings
The following table covers the Project Option settings specifically for Simple HTML 
Help in Publisher 2003.

Palm Reader Specific Settings
The following table covers the Project Option settings specifically for Palm Reader in 
Publisher 2003.

Accessibility Generate an accessibility report for this 
project after each conversion

Format > Format Settings > Generate 
accessibility report

 Validate that each image has an alt tag Format > Format Settings > Validate 
accessibility image alternate tags

 Validate that each image map hotspot 
has an alt tag

Format > Format Settings > Validate 
accessibility image map alternate tags

 Validate that each image has a long 
description

Format > Format Settings > Validate 
accessibility image long descriptions

 Automatically generate place holder 
long description files

Format > Format Settings > Validate 
accessibility image long descriptions

 Include visible [D] links to images that 
have long descriptions

Format > Format Settings > Include 
visible [D] links to images with long 
descriptions

 Validate that each table has a summary Format > Format Settings > Validate 
accessibility table summaries

Tab in 2003 Setting in 2003 ePublisher Equivalent

Tab in 2003 Setting in 2003 ePublisher Equivalent

TOC/IX Generate a Table of Contents file 
named

Format > Format Settings > Table of 
Contents filename

 Treat multi-level TOC transitions as Format > Format Settings > Collapse 
table of contents

 Generate an Index file named Format > Format Settings > Generate 
index / Index filename

 Use page titles as link text Not Support in GUI - Done by default

 Generate a Frameset file named Not Supported

Tab in 2003 Setting in 2003 ePublisher Equivalent

TOC/IX Generate an Index named Format > Format Settings > Generate 
index / Index filename

 Use page titles as link text Not supported in GUI - Done by default



Sun JavaHelp Specific Settings
The following table covers the Project Option settings specifically for Sun JavaHelp in 
Publisher 2003.

Microsoft Reader Specific Settings
The following table covers the Project Option settings specifically for Microsoft 
Reader in Publisher 2003.

Tab in 2003 Setting in 2003 ePublisher Equivalent

JavaHelp Title Format > Format Settings > Helpset 
title

 JAR File Filename is the value of the Group 
Name as specified in the Document 
Manager

 JH install location Format > Format Settings > JavaHelp 
location

 JDK install location Format > Format Settings > JDK 
location

 Include TOC navigator tab Format > Format Settings > Generate 
table of contents

 Include index navigator tab Format > Format Settings > Generate 
index

 Include search navigator tab Format > Format Settings > Enable 
search tab

TOC/IX Treat multi-level TOC transitions as Format > Format Settings > Collapse 
table of contents

Tab in 2003 Setting in 2003 ePublisher Equivalent

TOC/IX Generate a Table of Contents file 
named

Format > Format Settings > Table of 
Contents filename

 Treat multi-level TOC transitions as Format > Format Settings > Collapse 
table of contents

 Generate an Index file named Format > Format Settings > Generate 
index / Index filename

 Use page titles as link text Not Support in GUI - Done by default

Accessibility Generate an accessibility report for this 
project after each conversion

Format > Format Settings > Generate 
accessibility report

 Validate that each image has an alt tag Format > Format Settings > Validate 
accessibility image alternate tags



 Validate that each image map hotspot 
has an alt tag

Format > Format Settings > Validate 
accessibility image map alternate tags

 Validate that each image has a long 
description

Format > Format Settings > Validate 
accessibility image long descriptions

 Automatically generate place holder 
long description files

Format > Format Settings > Validate 
accessibility image long descriptions

 Include visible [D] links to images that 
have long descriptions

Format > Format Settings > Include 
visible [D] links to images with long 
descriptions

 Validate that each table has a summary Format > Format Settings > Validate 
accessibility table summaries

Tab in 2003 Setting in 2003 ePublisher Equivalent



Style Mappings Migration

External
Author: Ryan Hammett
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ePublisher Pro

The purpose of this article is to explain how to properly migrate Style Mappings 
in former versions of Publisher into an ePublisher Pro project. 

Before migrating a project from previous versions of Publisher to ePublisher Pro, you 
will need to double check your style mappings. If the mapping in your previous 
version of Publisher is set to type "By Name", then there is a chance that not all of the 
Source Styles will migrate over to ePublisher Pro. You will need to manually reselect 
the WebWorks Style to be mapped and this will change the type to "From Template".

For example, in the graphic below notice that the Source Styles have spaces between 
the name and the number. If the current mappings are left to “By Name”, they will not 
migrate over into ePublisher Pro.

Graphic illustrates default mappings set to type “By Name”.

Reselecting Style Mappings



1) Open your Publisher project.

2) For each Source Style that is set to type “By Name”, select the WebWorks Style and 
reselect the same WebWorks Style name to change the type to “From Template”.
Before:

After:



3) Repeat step 2 for each Source Style that you want to migrate over.

Change all styles set to type “By Name” to type “From Template”.

4) Save and migrate your project.

Note:In ePublisher Pro, notice that the source document style name is placed under the proj-
ect style name.



 

In ePublisher, Source Style names are placed under the Project Style names.



TOC Font Size Adjustment
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ePublisher Pro

The purpose of this article is to explain how to change the size of the headings in 
the TOC pane.

Some project modifications cannot be made through the GUI so we have created this 
article to provide steps for modifying the wwhelp_settings.xml file using project 
format overrides. When you create a project target override you are only overriding 
the specific file that you want to modify; you are also ensuring that these 
modifications are not lost when installing updates to ePublisher Pro. For more 
information on how to perform a project target override, please see ““Creating Project 
Target Overrides””.

Note:The default location of wwhelp_settings.xml is: C:\Program Files\WebWorks\ePub-
lisher Pro\Formats\WebWorks Help 5.0\Skins\Lobby_Blue.You must perform this proce-
dure for each skin that you wish to use.

Modifying wwhelp_settings.xml:
1) Open the wwhelp_settings.xml file in any text editor.

2) Scroll down untill you see the following code: 
<Implementations>

<JavaScript>

<Font style="font-family: Verdana, Arial, Helvetica, sans-serif ; 
font-size: 8pt" />

<Indent value="17" />

<AnchorColors highlight="#CCCCCC" enabled="#315585" 
disabled="black" />

3) Change the “font-size: 8pt” to desired font-size.

4) Save the wwhelp_settings.xml file.

5) Regenerate your project in ePublisher Pro.



Adobe PDF Printer Error

External
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ePublisher Pro

The purpose of this article is to explain how to troubleshoot if the message 
“Unable to create PostScript file” appears in the log file or you receive the 
following error message:

1) For Windows XP users, go to Start > Printers and Faxes. For Windows 2000 users, go 
to Start > Settings > Printers.

2) Check to see if the Acrobat Distiller printer exists.

3) If the Acrobat Distiller printer does not exist, reinstall FrameMaker and click Yes when it 
asks you if you would like to install Acrobat Distiller.

4) After the repair is finished, go back to your Printers folder and verify that the Acrobat 
Distiller printer exists.

5) Regenerate your WebWorks ePublisher Pro project.



AltText Work Around
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ePublisher Pro

The purpose of this article is to explain how to make the AltText attribute 
function correctly.

AltText is a common HTML element in many web pages, but it behaves differently in 
different browsers. Often, the alt attribute is incorrectly referred to as an image’s alt 
tag. It is not intended to provide "pop up" text or tooltip when a user's mouse hovers 
over the image, though AltText has been presented in this way in some web browsers; 
actually HTML's title attribute is intended for supplementary information that can 
be used in this way. 

Internet Explorer passes the AltText attribute alt as a tooltip when a user’s mouse 
hovers over the image and we have many customers who expect this behavior when 
they are viewed in FireFox. The work around provided below will result in tooltip-
style behavior of AltText in FireFox.

Some project modifications cannot be made through the GUI so we have created this 
article to provide steps for modifying the content.xml  file using project target 
overrides. When you create a project target override you are only overriding the 
specific file that you want to modify; you are also ensuring that these modifications 
are not lost when installing updates to ePublisher Pro. For more information on how to 
perform a project target override, please see “Creating Project Target Overrides”.

Note:content.xsl file is located by default in: C:\Program Files\WebWorks\ePublisher 
Pro\Formats\WebWorks Help 5.0\Transforms.

Modifiying the content.xsl file:
1) Open content.xsl file in notepad.

2) Search for the following code:
<xsl:attribute name=”alt”>

<xsl:value-of-select=”$VarAltText”/>

</xsl:attribute>

Note:In content.xsl  this code is declared three times in the content.xsl file. The follow-
ing changes must be applied to each instance to achieve the desired results.

3)  Please insert the following code below the top code:
<xsl:attribute name=”title”>



<xsl:value-of-select=”$VarAltText”/>

</xsl:attribute>

4) Please Save your content.xsl.

5) Close content.xsl.

6) In ePublisher Pro, select project > Regenerate All. 



Assigning Images for Bullets
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ePublisher Pro

The purpose of this article is to explain how to assign images as bullets.

In ePublisher Pro, users can use custom images as bullets in any paragraph style. The 
steps below will walk you through this process.

Replacing images for bullets:
1) In your ePuslisher Pro project, select View > User Files.

2) Place the image you would like to use as your bullet style in the User Files folder.

3) Select View > Style Designer.

4) Select the paragraph style that you would like to assign the custom bullet image to.

5) Choose Bullet from the list of properties.

6) Click on the dropdown button next to the Images property.

7) Select a bullet image from the list of available images.

8) Close the Style Designer.

9) Select Project > Regenerate All.



Creating Thumbnails
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ePublisher Pro

The purpose of this article is to explain how to create thumbnails.

 This article will show you how to create thumbnails in WebWorks ePublisher Pro.

Creating Thumbnails
1) In ePublisher Pro, select View > Style Designer.
2) Select the Graphic Styles tab.

3) From the list of graphic styles, select Default.
4) Select the Options tab.

5) Find the option Thumbnail threshold height.

6) Do one of the following:

a) Click on the dropdown button next in the value field to enable the dropdown menu, 
and select a value from the list.

b) Click inside the value field, and type in the value you would like to use.

Note:We recommend using 100 or higher.

7) Find the option Thumbnail threshold width.

8) Do one of the following:

a)  Click on the dropdown button next in the value field to enable the dropdown menu, 
and select a value from the list.

b) Click inside the value field, and type in the value you would like to use.

Note:We recommend using 100 or higher.

Threshold height and width draws an image box 100 by 100 and makes your image to fit inside of this box. It 
doesn’t stretch your diagonal or small images to fit into this box. This feature makes all of your images appear 
no larger than the specified size.

This is how threshold image works in ePublisher Pro:



9) If you have created a page style for your thumbnails, find the option Thumbnail Page 
Style. If you dont have a page style for your thumbnails, proceed to step 12.

10) Click on the dropdown button in the value field to enable the dropdown  menu. A list of 
available page styles will display.

11) Select a page style from the dropdown list.

12) Close the Style Designer.

13) Select Project > Regenerate All.



Windows and Dialogs are Not Sized Correctly

External
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WebWorks ePublisher Pro

The purpose of this article is to resolve the issue behind the display of 
select dialog boxes within ePublisher Pro.

In ePublisher Pro, users can run into problems if their desktop is set too 
high (e.g., 120DPI). Often, this results in the improper display of dialogs 
like the splash screen and the new project dialogs, hiding specific aspects 
on those boxes, rendering them useless.

Note:When you try to create a new project you wont be able to use stationary  
with DPI setting set to Large Size (120 DPI).



Note:This is what your About ePublisher Pro image will look like if your DPI 
setting is set to Large Size (120 DPI).

To Change DPI settings in Windows:
1) Open Control Panel > Display.

2) From Display Properties select Settings.

3) Choose Advanced and Select General.

4) In Display change the DPI Setting to Normal size (96 DPI).

5) Click OK to apply the new setting.



Embedding Media Files 
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ePublisher Pro

The purpose of this article is to explain how to embed  media files into a 
WebWorks Help 5.0, Dynamic HTML,  Microsoft HTML Help 1.x, and Simple 
HTML Help systems.

In the following article, we will show you how to embed the proper code into the 
source document and how to set up your ePublisher Pro project to then use that 
markup successfully when generating output.

Embedding Conditional Markup in the Source File
In the following steps, we will be inserting code into the source document using 
conditional text. This code can be processed by ePublisher Pro to be emitted in the 
HTML of the resulting output, producing an embedded media file.

For Adobe FrameMaker:
1) In the source document, place the insertion point where you want the embedded 

media file to appear.

2) Insert the <embed></embed> code at the insertion point. An example of this usage 
is: 

<embed src="sample.swf" width="400" height="300" pluginspage=" http://
www.macromedia.com/shockwave/download/
index.cgi?P1_Prod_Version=ShockwaveFlash";>

</embed>

3) Select and highlight this code.

4) Special > Conditional Text...

5) Click the Edit Condition Tag...button

6) In the Tag field, type the name of your Condition. In this example we are going to 
name our tag Media.

7) Set your Condition Indicators (these are just visible formatting rules that enable 
you to see the conditional text in the Framemaker document).

8) Click the Set button to close the Edit Condition Tag dialog.

9) You will see Media is not listed in the ‘Not in’ list. Double-click Media.



10) Click Apply.

11) Save the source document.

For Microsoft Word:
1) In the source document place the insertion point where you want the embedded 

media file to appear.

2) Insert the <embed></embed> code at the insertion point. An example of this usage 
is:   

<embed src="sample.avi" width="400" height="300" pluginspage=";>

</embed>

Note:In order to embed a video file into Microsoft HTML Help 1.x system please use 
the code below:

<img start="MOUSEOVER" loop="1" DYNSRC="sample.avi">

3) Select this code in the sourcedocument and apply your condition.

4) Select Webworks > Conditions.

5) Click the Add Condition button to open the Create New Condition dialog and click 
OK.

6) Name your condition by entering the name and click OK.

Note:In this example we are going to name our tag “Media”.

7) From Configure Conditions list find the condition you just created.

8) Click the Apply Condition button and then click OK to close the dialog.

9) Save the source document.

Setting up your ePublisher Pro Project
After you have placed the code and conditions in your source document you must set 
up your ePublisher Pro project to process the code properly.

1) Open your WebWorks ePublisher Pro project.

2) Select View > User Files.

3) Copy your media file(s) in this location.

Note:Media Files cannot be embedded unless they are included in the ‘Files’ folder.

4) Close Files folder.

5) Select Project > Scan All Documents to scan in your new conditions.

6) Select Format > Conditions.

7) From the Conditions tab, find the name of the condition(s). In our example, the 
condition name is Media.

8) Verify that Visible and Pass Through are selected.



9) Click OK.

10) Select Project > Generate All.
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The purpose of this article is to explain how to set up your project and your 
system for creating a JavaHelp system.

In order to create a JavaHelp system, we recommend having the latest JDK installed 
on your machine. The JDK is offered as part of the Java Platform, Standard Edition 
(Java SE). The link above takes you to the Java SE (previously known as J2SE) 
download page, from which you can obtain the current JDK. Installation instructions 
and documentation is available at this link. http://java.sun.com/javase/downloads/
index.html.

After Downloading the J2SE(TM) Development Kit 5.0 Update 6 to your machine 
please be sure to do following:

1) Open your WebWorks ePublisher project. Ensure JavaHelp is the active target for 
the project.

2) Go to Project > Format Settings.

3) Find JavaHelp Location setting. Enter the location of the JavaHelp installation

• The default Location for JavaHelp 1.1.3 will be C:\Program Files\Web-
Works\ePublisher Pro\Helpers\javahelp1.1.3\javahelp\bin

• The default Location for JavaHelp 2.0 will be C:\Program Files\WebWorks\ePub-
lisher Pro\Helpers\javahelp2.0\javahelp\bin

4) Find JDK location setting. Enter the location of the JDK installation. The default 
location for JDK installations can be one of two places. If your hard drive is the C:\, 
then the installation can be placed at C:\Program Files\Java\[JDKInstallation] or 
C:\[JDKInstallation]. Where JDK Installation is named for the version of the JDK 
that you have installed. 

http://java.sun.com/javase/downloads/index.html
http://java.sun.com/javase/downloads/index.html
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The purpose of this article is to explain how to open your links to external files in 
a new browser window. 

Some project modifications cannot be made through the GUI so we have created this 
article to provide steps for modifying the content.xsl file using project target overrides. 
For more information on how to perform a project target override, please see 
““Creating Project Target Overrides””.

Note:content.xsl file is located by default in: C:\Program Files\WebWorks\ePublisher 
Pro\Formats\[FORMAT]\Transforms. Where [FORMAT] is the format from which you have 
based the target being generated.

Modifying the content.xsl file
1) Open the new content.xsl file in the project directory with the text editor of your choice.

2) Copy this code:
<xsl:variable name="VarTarget" 
select="wwprojext:GetFormatSetting('external-url-target', '_window')" />

<xsl:if test="(string-length($VarTarget) &gt; 0) and ($VarTarget != 
'none')">

<xsl:attribute name="target">

<xsl:value-of select="$VarTarget" />

</xsl:attribute>

</xsl:if>

3) Search for the comment, <!-- Baggage -->.

4) Paste the code in between the following code, located under <!-- Baggage --> 
</xsl:attribute>

----->

</xsl:when>

5) Save content.xsl file and close it. 

6)  In your ePublisher Pro project, select Project > Regenerate All. 
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The purpose of this article is to explain how to modify breadcrumbs using project 
target overrides for changes to an ePublisher Pro project that are not available 
through the GUI. 

Some project modifications cannot be made through the GUI so we have created this 
article to provide steps for modifying breadcrumbs using project target overrides.  
When you create a project target override you are only overriding the specific file that 
you want to modify; you are also ensuring that these modifications are not lost when 
installing updates to ePublisher Pro.

1) Create a project target override by following the steps in “Creating Project Target 
Overrides”

2) The file that you have just copied will be the file to which you will make your 
modifications.

Note:It is not necessary to copy any files into the project Targets directory that you are 
not explicitly overriding.

3) You can open the webworks.css file in a text editor, such as Notepad, locate the 
Breadcrumbs css classes WebWorks_Breadcrumbs and WebWorks_Breadcrumb_Link, 
and modify the CSS style information to reflect the style you want.

4) After you have made all modifications you want to make, save the file and the next time 
you Generate All in your ePublisher Pro project, this file will be used in place of the 
default file (thus overriding it), and the changes you made will be incorporated into the 
output. 

Note:If you save the ePublisher Pro project as stationery, the project target overrides you have 
created will be saved in your stationery.This stationery can then be used to create future proj-
ects, while maintaining these modifications throughout your future projects.
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The purpose of this article is to explain how to modify the appearance of multiple 
hyperlinks.

Currently, there is not a way through the UI to control the appearances of multiple 
hyperlinks.  In other words, users often want the appearance of their hyperlinks to be 
different depending on the type of hyperlink it is (external, glossary, popup, file, etc.), 
and there is not a way to do this through the UI. We are looking at adding this 
capability in the future. For now, customers will need to use this workaround.

The workaround is to apply unique character styles to the hyperlinks and then create a 
project target override on the webworks.css file and add the desired CSS style 
information. For more information on how to create a project target override, please 
see ““Creating Project Target Overrides””.

Note:By default the webworks.css file lies in C:\Program Files\WebWorks\ePublisher Pro\For-
mats\[FORMAT]\Pages\css. Where [FORMAT] is the format from which the target to be gener-
ated is based. 

Example
Suppose you have a hyperlink in your source document with a character style applied 
to it called MyHyperlinkCharacterStyle and you want the link to appear green with no 
underline in output. 

In the webworks.css file you would add the following:

.MyHyperlinkCharacterStyle a:link{

color: green;

text-decoration: none;

}

.MyHyperlinkCharacterStyle a:visited{

color: green;

text-decoration: none;

}



.MyHyperlinkCharacterStyle a:hover{

color: purple;

text-decoration: none;

}

.MyHyperlinkCharacterStyle a:active {

color: green;

text-decoration: none;

}

Note:There are four CSS states for links: link, active, visited and hover. The link state 
indicates a link that has not been used nor is there a mouse pointer hovering over it. The 
active state indicates a link is in the process of being clicked. The visited state indicates a 
link has been used and there is not a mouse pointer hovering over it. The hover state indi-
cates a mouse pointer is hovering over a link.

Once you are finished modifying the CSS information, save and close the 
webworks.css file and regenerate your project. If you would like to see an example 
project, you may download it here.
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The purpose of this article is to explain how to modify the Page.asp file using 
project target overrides for changes to an ePublisher Pro project that are not 
available through the GUI. 

Some project modifications cannot be made through the GUI so we have created this 
article to provide steps for modifying the Page.asp file using project target overrides.  
When you create a project format override you are only overriding the specific file that 
you want to modify; you are also ensuring that these modifications are not lost when 
installing updates to ePublisher Pro.

Instructions for creating project target overrides
1) Select the existing format target from your project.

For example, if you chose WebWorks Help 5.0 as the format when creating this project you will already have 
a target that, by default, is named WebWorks Help 5.0. 

Figure 1WebWorks Help 5.0 is the Active Format Target shown below

2) Open your existing ePublisher Pro project if it is not already open.

3) Go to View > User Files.

4) Navigate up one level to the same directory where your .wep ePublisher Pro project 
file is located.

5) Create a new folder named Targets.

Note:The directories ePublisher Pro looks for are case-sensitive. Be sure to type the folder 
names exactly the way they are typed in the installation directory structure.



6) Open the Targets directory you just created.

7) Create a new folder and assign it the name of the Active Format Target in your project. 
See Figure 1

8) Open the WebWorks Help 5.0 directory you just created. Leave this window open.

9) Open a new explorer window and navigate to the Formats folder located in the 
ePublisher Pro installation directory. By default, it is located in C:\Program 
Files\WebWorks\ePublisher Pro\Formats. 

10) Within the Formats directory, open the directory of the format from which you have 
based the target, chosen in step 1.
For example, if the target you are creating overrides for is based on the WebWorks Help 5.0 format, you 
should open the WebWorks Help 5.0 directory in Formats.

11) Navigate to page.asp, select it, right-click and choose Copy to copy the file. 

12) Within the Targets directory that you created in step 5, recreate the directory path that 
leads to the file you copied in step 11. Then paste the copied file here.
For this example, since you are overriding the page.asp file for your new format target based on the 
WebWorks Help 5.0 format, you would create within your new Targets directory a new folder called 
Pages, and paste the file here. 

Page.asp
1) In the steps above you will have copied and pasted Page.asp into your project 

directory and will be making the modifications to this file.

Note:It is not necessary to copy any files into the project Targets directory that you are 
not explicitly overriding.

2) After you have made the modifications you want to make to the file in your project 
directory, save the file and the next time you Generate All in your ePublisher Pro project, 
this file will replace the default file (thus overriding it), and the changes you made will 
be incorporated into the output. 

3) When you save the ePublisher Pro project as stationery, the project target overrides 
you have created will be saved in your stationery.
This stationery can then be used to create future projects, while maintaining these modifications throughout 
your future projects.
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This article describes how to fix the “No valid license key found to enable Adobe 
FrameMaker (or Microsoft Word) support” error.

If you receive either of the following errors: “No valid license key found to enable 
Adobe FrameMaker support” or “No valid license key found to enable Microsoft 
Word support”, this means you have an old or invalid key in the License Key field, or you 
have not entered the correct ePublisher Pro key to activate the product for Word or 
FrameMaker.

Please follow these instructions to enter a valid license key:

1) First, delete any existing license keys that appear in the License Information field.

2) Open WebWorks ePublisher Pro, and select Help > License Keys....

3) Enter your license key into the License Key field. Do not enter any extra spaces, and 
make sure there is not a space preceding the license key in the License Key field.

Note:Separate keys are required to activate ePublisher Pro for Word and for FrameMaker 
files.

4) Press the Add Key button.

5) Press OK.
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The purpose of this article is to explain how to create project target overrides for 
changes to an ePublisher Pro project that are not available through the GUI. 

Some project modifications cannot be made through the GUI so we have created this 
article to provide steps for creating these project target overrides.  Examples of 
modifications that cannot be made through the UI are changing the splash page to a 
WebWorks Help system, TOC font size adjustment to your project for localization 
purposes, and modifying style properties for breadcrumbs and mini-TOCs. When you 
create a project target override you are only overriding the specific file that you want 
to modify; you are also ensuring that these modifications are not lost when installing 
updates to ePublisher Pro.

This article offers general steps for performing target overrides. These steps may be 
taken with any of the files you need to modify inside the Formats directory. Please 
note however that changes to XSL and FTI files are not supported through our Product 
Support department. Modification of these files will only be supported through our 
Services department.

Instructions for creating project target overrides
To create a target override, we will first choose an existing format target in our project. 
Next, we will create a directory structure that mirrors the directory path to the file that 
we will be overriding. 

Please follow these instructions to create target overrides:

1) Select the existing format target from your project.
For example, if you chose WebWorks Help 5.0 as the format when creating this project you will already have 
a target that, by default, is named WebWorks Help 5.0. 

Figure 1WebWorks Help 5.0 is the Active Format Target iseen below.



Next, we will create a new Targets directory in our ePublisher project directory. 

2) Open your existing ePublisher Pro project if it is not already open.

3) Go to View > User Files.

4) Navigate up one level to the same directory where your .wep ePublisher Pro project 
file is located.

5) Create a new folder named Targets.

Note:The directories ePublisher Pro looks for are case-sensitive. Be sure to type the folder 
names exactly the way they are typed in the installation directory structure.

6) Open the Targets directory you just created.

7) Create a new folder and assign it the name of the Active Format Target you have 
selected in your project. See Figure 1

8) Open the directory you just created. Leave this window open.

9) Open a new window and navigate to the Formats folder located in the directory where 
you installed WebWorks ePublisher Pro. By default, it is located in C:\Program 
Files\WebWorks\ePublisher Pro\Formats. 

10) Within the Formats directory, open the directory of the format on which you have based 
the format target, chosen in step 1.
For example, if the target you are creating overrides for is based on the WebWorks Help 5.0 format, you 
should open the WebWorks Help 5.0 directory in Formats.

11) Navigate to the file you need to override, select it, right-click and choose Copy to copy 
the file. 
For our example format target (which is based on the WebWorks Help 5.0 format), if you want to override the 
webworks.css file, you would open the Pages > css directory and copy the webworks.css file. 
The default installation path to webworks.css would be: C:\Program 
Files\WebWorks\ePublisher Pro\Formats\WebWorks Help 5.0\Pages\css



12) Within the Targets directory that you created in step 5, recreate the directory path that 
leads to the file you copied in step 11. Then paste the copied file here.
For this example, since you are overriding the webworks.css file for your new format target based on the 
WebWorks Help 5.0 format, you would create within your new Targets directory a new folder called 
Pages, and within that another directory called css. 

Note:If the file you need to override is located in the “Shared” directory, then you should 
recreate this folder inside the one named for your active target.  For example, you might 
have a hierarchy in your project folder like this:
   Targets\WebWorks Help 5.0\Shared\common\locale\locales.xml

13) The file you have just pasted will be the file that you will make your modifications to.

Note:It is not necessary to copy any files into the project Targets directory that you are 
not explicitly overriding.

14) After you have made the modifications you want to make to the file in your project 
directory, save the file and the next time you Generate All in your ePublisher Pro project, 
this file will replace the default file (thus overriding it), and the changes you made will 
be incorporated into the output. 

15) When you save the ePublisher Pro project as stationery, the project target overrides 
you have created will be saved in your stationery.
This stationery can then be used to create future projects, while maintaining these modifications throughout 
your future projects.
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The purpose of this article to help troubleshoot when receiving the message:

[Error] An error occurred in pipeline 'Splits' while processing stage transform 
'wwtransform:common/splits/names.xsl'.

[Error] Function 'wwfilesystem:Combine()' has failed.

[Error] Exception has been thrown by the target of an invocation.

[Error] The given path's format is not supported.

If you are receiving this error message, then you have probably used a special 
character in your filename markers. You will need to open your document and check 
all your filename markers to ensure that there are no special characters. 

Note:Special characters include: \ / : * ? " < > |

For example, if you had a filename marker that had the marker text myoutput : 
myfilename you would receive the error message. This is because you cannot have 
special characters in file paths. In this example, you would need to remove the colon 
and have the marker text read myoutput_myfilename or myoutput myfilename.
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