Website Deliverables - Previous Next Index Print
Adding Multiple HTML Help Header Files

Adding Multiple HTML Help Header Files

Last Modified: July 12, 2006

ePublisher Pro

The purpose of this article is to explain how to add multiple Microsoft HTML Help header files (.h extension) to a WebWorks ePublisher Pro Project.

Some project modifications cannot be made through the GUI so we have created this article to provide steps for adding multiple Microsoft HTML Help header files by using project target overrides. When you create a project target override you are only overriding the specific file that you want to modify; you are also ensuring that these modifications are not lost when installing updates to ePublisher Pro.

Creating a target override for template.hhp

To create a target override, we will first choose an existing format target in our project. Next, we will create a directory structure that mirrors the directory path to the file that we will be overriding.

Please follow these instructions to create target overrides:


Go to View > User Files.


Navigate up one level to the same directory where your .wep ePublisher Pro project file is located.


The directories ePublisher Pro looks for are case-sensitive. Be sure to type the folder names exactly the way they are typed in the installation directory structure.


Open the Targets directory you just created.


Create a new folder and assign it the name of the Format Target you have selected in your project.


Open the Format Target directory you just created. Leave this window open.


Open a new window and navigate to the Microsoft HTML Help 1.x folder located within the Targets directory where you installed WebWorks ePublisher Pro. By default, it is located in C:\Program Files\WebWorks\ePublisher Pro\Formats\Microsoft HTML Help 1.x.


Open the Pages folder.


Navigate to the template.hhp file, select it, right-click and choose Copy to copy the file.


Within the Targets directory that you created in step 5, recreate the directory path that leads to the file you copied in step 11.Then paste the copied file here.

For this example, since you are overriding the template.hhp file for your new format target based on the Microsoft HTML Help 1.x format, you would create within your new Targets directory a new folder called Pages, and paste the copied file here.


It is not necessary to copy any files into the project Targets directory that you are not explicitly overriding.

Modifying the HTML Help Project File


Open the template.hhp file you just created in a text editor.


Change the $MapFile; string under the [Map] heading with the names of your multiple header files.

For Example:

#include "MyHeader1.h"
#include “MyHeader2.h”
#include “MyHeader1000.h”


When you are finished adding your files, save the template.hhp file and the next time you Generate All in your ePublisher Pro project, this file will replace the default file (thus overriding it), and the changes you made will be incorporated into the output.


When you save the ePublisher Pro project as Stationery, the Project Target Overrides you have created will be saved in your Stationery.

Adding Multiple Header Files to ePublisher Pro


Go to View > User Files.


Go to Project > Generate All.