
WebWorks Help 5.0

Originally introduced in 1998, WebWorks Help is an output format that allows 
online Help to be delivered on multiple platforms and browsers, which makes it 
easy to publish information on the Web or on an enterprise intranet. Whether 
your Help system needs to be viewed on a Macintosh or Windows operating 
system, displayed with Mozilla Firefox, Safari, Internet Explorer, or Netscape, 
WebWorks Help 5.0 provides you with a flexible and adaptable Help system.

About WebWorks Help
WebWorks Help combines standard HTML and CSS1 and CSS2 with JavaScript 
to provide users with navigational controls found in typical Help systems, 
inlcuding an expandable/collapsible table of contents, an index, full text search, 
breadcrumbs and Related Topics menus.WebWorks Help can be easily integrated 
with applications written in C, C++, Java, or Visual Basic, as well as Web-based 
applications, which allows you to create and deploy context-sensitive Help 
easily. 

WebWorks Help enables you to publish your content in a variety of ways. The 
WebWorks Help system can be installed locally on the end user’s computer, 
made available to multiple users on a network share, published on a CD-ROM, or 
hosted on an intranet Web server. 

Requirements for Developing WebWorks Help

To develop WebWorks Help, the latest version of WebWorks ePublisher Pro is 
recommended. To obtain the latest version of ePublisher Pro, please visit our 
download center at http://www.webworks.com.

In addition to the latest version of ePublisher Pro, your system at least should 
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Formats: WebWorks Help 5.0
meet the minimum system requirements for running ePublisher Pro; however, for 
optimal performance, we recommend that your system meet our preferred system 
requirements.

Minimum System Requirements

• Microsoft Windows 2000

• Microsoft Internet Explorer 5.5 (Service Pack 4) or greater, with JavaScript 
enabled

• Microsoft Word 2000 or greater

• Adobe FrameMaker 6.0 or greater

• 512 MB RAM

• Pentium IV or equivalent

• Microsoft .NET 1.1 or greater

Preferred System Requirements

• Microsoft Windows XP

• Internet Explorer 6.0 with JavaScript enabled

• Microsoft Word 2003

• Adobe FrameMaker 7.1 or 7.2

• 1 GB RAM

• At least 200 MB free hard disk space

• 3 GHz or faster Pentium IV or AMD processor

• Microsoft .NET 1.1 or greater 

Requirements for Viewing WebWorks Help

In order to view WebWorks Help systems, users must have a Windows, 
Macintosh, or UNIX computer running a supported browser with JavaScript 
enabled. If JavaScript is not enabled, then the Help set will not display in its 
entirety. To find out if JavaScript is enabled, consult the browser’s options. 

WebWorks Help 5.0 has been tested on Internet Explorer 5.x and 6.x, Mozilla 
Firefox 1.x, Netscape 7.x and 8.x, Safari 1.x and 2.x, and Opera 7.54u2 and 8.x.
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WebWorks Help User Interface
When a WebWorks Help system launches, it can either display the frameset view 
or the topic view in the browser window. The view that displays depends on 
whether the user is calling context-sensitive Help or the entire Help system.

The Frameset View

The frameset view divides the browser window into three areas: an area for 
navigational controls, an area for toolbar buttons, and an area for Help topics. 
This view gives the user maximum control and is commonly used to display 
online Help requested from the Help menu and to display electronic books and 
other forms of online information. 

The frameset view utilizes a frameset file that divides the browser into three main 
areas:

• The Navigation Frame

• The Toolbar Frame

• The Topic Frame
WebWorks ePublisher Pro Format Guide 3
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The Navigation Frame

By default, the navigation frame displays four tabs: Contents, Index, Search, and 
Favorites. These tabs provide end users with core navigational features for your 
Help system.

The Contents Tab

The Contents tab contains the table of contents. All styles that have been 
assigned a TOC level will be displayed in the Contents pane. Users can click on 
items in the Content pane to view the topic. While browsing through topics in the 
table of contents, the item selected will auto-sychronize with the content in the 
topic pane.

The Contents tab displays the table of contents in the form of an 
expandable/collapsible tree view. Each book icon represents a TOC entry that has 
subentries. A user can click on a closed book to open it to see its contents. When 
you expand a book, the closed book icon is replaced by an open book icon. The 

The navigation frame The toolbar The topic frame
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page icon represents individual Help topics in the Help set.

The Index Tab

The Index tab displays an alphabetical list of keywords associated with topics. To 
view index entries, the user can select a letter group to display the entries for that 
group. When the user clicks on an index entry, the related topic will display in the 
topic frame. 

The keywords are defined by the Help author; in the source document, the author 
needs to embed index markers or index fields on keywords that will appear in the 
index. To learn more about embedding index markers or index fields, please 
consult your authoring tool’s documentation.
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The Search Tab

The search tab displays a search field where the user can enter text, then select 
Go to return results related to the search text. The title whose content contains the 
word or phrase will be listed below the search field. 

All topics that contain the word or phrase that matches the search entry will 
display under Rank and Title fields. Each returned search result will have a 
relevancy ranking, which is the number that displays next to the topic. The 
relevancy ranking reflects how well the returned search result has matched the 
search criteria specified in wwh_files.xsl. For more information on how to 
modify the ranking relevancies, please see “Modifying the Search Rank” on 

Index letter 
groups

Keywords

Related index 
entries
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page 56.

The Favorites Tab

In WebWorks Help systems, users can add frequently accessed Help topics to a 
personal list of favorites. When users add a topic as a favorite, the topic will 
display on the Favorites tab when the tab is selected. 

The list of favorites will be available anytime the Favorites tab is selected. By 
using the Favorites tab, users can easily access frequently visited Help topics or 
bookmark important Help topics. When the user clicks on any of the Help topics 
on the Favorites list, the Help topic will display in the Topic frame. 

The favorites tab also contains a Remove button that allows users to delete any 
unwanted topics.

Search field

Ranking 
relevancy

Search results

Help topic

Added 
favorites

Remove 
button
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The Toolbar Frame

By default, the toolbar frame displays a set of buttons that provides users with 
additional functionality and navigational resources. These toolbar buttons allow 
the users to navigate through the content of the Help set.

The standard WebWorks Help toolbar comes with the following buttons:

• Show in Contents button: Use this button to locate where the currently 
displayed topic is in the Contents tab. When you click on this button, 
WebWorks Help highlights the entry in the Contents tab that corresponds to 
the currently displayed topic. 

• Previous button: Click on the Previous button to display the topic that 
precedes the currently displayed topic.

• Next button: Click on the Next button to display the topic that follows the 
currently displayed topic.

• PDF button: Click on the PDF button to display a PDF of the source 
document from which the currently displayed topic resides.

• Related Topics button: Click on the Related Topics button to open a menu 
that lists topics related to the currently displayed topic. You must set up 
Related Topics in your FrameMaker file in order for the Related Topics 
button to work correctly in your Help system. For more information, please 
see “Creating Related Topics” on page 23.

• Print button: Click on the Print button to print the currently displayed topic.

• E-mail button: The E-mail button enables you to gather feedback by e-mail 
from the users of your WebWorks Help system. When a user clicks on this 
button, the user’s email program opens a new, blank message addressed to an 
e-mail you specify. The Subject line of the message identifies the Help topic 
that was displayed when the user clicked the button.

The Topic Frame

The output pages that are generated from your source documents will display in 
the topic frame. Anytime a user selects a topic from the Contents, Search, Index, 
or Favorites tab, the topic page will display in the Topic frame.
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Topic Only View

The topic only view displays only two areas: an area for toolbar buttons and 
another for Help topics. Using the topic only view, an application can open a 
smaller browser window that leaves more room onscreen for the application 
itself. Typically, context-sensitive Help uses the topic only view.

Customizing WebWorks Help
You can customize the appearance of your WebWorks Help set. By customizing 
your WebWorks Help set, you can add different functionalities and features to 
your Help system. There are two types of customizations: standard 
customizations and WebWorks Help specific customizations. 

Standard Customizations

Standard customizations refer to any modifications that can be made to most 
formats, such as adding your company’s contact information or specifying the 
HEX color value for your hyperlinks. Within each format, there are different 
methods of implementing standard customizations. In the following sections, we 
will cover the standard customizations that are applicable to WebWorks Help 5.0.

Note:  Typically, customizations to the WebWorks Help 5.0 format will require 
that you create a project format override. 

These are the standard customizations that you can apply to WebWorks Help:

• Customizing hyperlink colors

• Adding a logo to your topic pages

• Modifying the company contact information

• Displaying company contact information

• Disabling autonumbering from appearing in output

• Modifying Page.asp

• Creating popups
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• Creating Related Topics menus

• Creating context-sensitive Help

Customizing Hyperlink Colors

Hyperlink colors are controlled by anchor classes defined in webworks.css. The 
HEX color values of any of the anchor tags (e.g., a:link:active, a:visited, 
a:link:hover, and a:link) can be replaced with any color HEX value.

To change the color of hyperlinks:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:

2. Navigate to C:\Program Files\WebWorks\ePublisher Pro\Formats\WebWorks 
Help 5.0\Pages\css.

3. Copy webworks.css.

4. Paste webworks.css into the css folder in the project format override.

5. Open webworks.css with a text/html editor.

6. Find the following block of code:
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a:link:active { color: #0000CC}
a:link:hover { color: #CC0033}
a:link { color: #3366CC}
a:visited { color: #9999CC}

7. Replace any of the color values with the HEX values you would like to use. 

• a:link:active controls the color of the link when it is selected.

• a:link:hover controls the color of the link when the user hovers over the 
link.

• a:link controls the color of unvisited links.

• a:visited controls the color of links that have already been visited.

8. Save webworks.css.

9. In ePublisher Pro, go to Project > Regenerate All.

Adding a Logo 

If you add a logo image to your project, the logo will display alongside your 
company contact information on the top and/or bottom of the output pages in 
your Help system. There is a three-step process in order to get your logo image to 
display in your output. First, you must place the image that will be used as the 
logo in the User Files directory; next, you must select the image in Format 
Settings; finally, you must enable company information to display by using the 
Style Designer.

To add a logo:

1. In ePublisher Pro, select View > User Files.

2. Place the logo image into this directory.

3. Select Format > Format Settings.

4. Click on the value field next to the Company logo image setting.

5. Type in the name of the logo image (e.g., logo.gif) or click on the button 
to select the image from the User Files directory.

6. Click OK to close the Format Settings dialog box.

7. Select View > Style Designer.
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8. Click on the Page Styles tab.

9. Select the Default page style.

10. Click on the Options tab.

11. Enable the company information for the top and/or the bottom.

12. Close the Style Designer.

13. Select Project > Regenerate All.

Modifying the Company Contact Information

You can add your company’s contact information to each output page in your 
Help system. By default, the company contact information can display on the 
bottom and/or top of your output pages. You specify where the company contact 
information displays by enabling the Company info displayed at top or Company 
info displayed at bottom options in the Style Designer.

With WebWorks Help 5.0, you can specify your company’s name, e-mail 
address, phone number, fax number, and Web page.

Note:  Once you have specified your company’s contact information, you will 
need to enable the Company info display options in the Style Designer. For more 
information, please see “Displaying Company Contact Information” on page 14.

To modify the company e-mail address:

1. Select Format > Format Settings.

2. Find the setting Company email address. 

3. In the Value field, type in the e-mail address (e.g., info@webworks.com).

4. Click OK to close the Format Settings dialog box.

Note:  In order to display company information on the output pages, you 
must have the company information option enabled in the Style Designer. For 
more information, please see “Displaying Company Contact Information” on 
page 14.

To modify the company fax number:
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1. Select Format > Format Settings.

2. Find the setting Company fax number. 

3. In the Value field, type in the fax number (e.g., 1-800-555-5555).

4. Click OK to close the Format Settings dialog box.

Note:  In order to display company information on the output pages, you 
must have the company information option enabled in the Style Designer. For 
more information, please see “Displaying Company Contact Information” on 
page 14.

To modify the company name:

1. Select Format > Format Settings.

2. Find the setting Company name. 

3. In the Value field, type in the company’s name (e.g., Quadralay 
Corporation).

4. Click OK to close the Format Settings dialog box.

Note:  In order to display company information on the output pages, you 
must have the company information option enabled in the Style Designer. For 
more information, please see “Displaying Company Contact Information” on 
page 14.

To modify the company phone number:

1. Select Format > Format Settings.

2. Find the setting Company phone number. 

3. In the Value field, type in the phone number (e.g., 1-800-555-5555).

4. Click OK to close the Format Settings dialog box.

Note:  In order to display company information on the output pages, you 
must have the company information option enabled in the Style Designer. For 
more information, please see “Displaying Company Contact Information” on 
page 14.
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To modify the company Web page:

1. Select Format > Format Settings.

2. Find the setting Company webpage. 

3. In the Value field, type in the URL to the company’s website (e.g. 
http://www.webworks.com).

4. Click OK to close the Format Settings dialog box.

Note:  In order to display company information on the output pages, you 
must have the company information option enabled in the Style Designer. For 
more information, please see “Displaying Company Contact Information” on 
page 14.

Displaying Company Contact Information

After you have specified your company’s contact information – such as your 
company’s name and phone number – you need to enable either one or both of 
the Company info display options in the Style Designer. 

If you open the Style Designer and click on the Page Styles tab, and then click on 
the Options tab, you will see that there are two options to enable where your 
company contact information is located: Company info displayed at bottom or 
Company info displayed at top.

To display company information at the top of your topic page:

1. Select View > Style Designer.

2. Click on the Page Styles tab.

3. Select the Default page style.

4. Click on the Options tab.

5. Find the option Company info displayed at top.

6. Click on the drop-down button and select Enabled.

7. Close the Style Designer.

8. Select Project > Regenerate All.
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To display company information at the bottom of your topic page:

1. Select View > Style Designer.

2. Click on the Page Styles tab.

3. Select the Default page style.

4. Click on the Options tab.

5. Find the option Company info displayed at bottom.

6. Click on the drop-down button and select Enabled.

7. Close the Style Designer.

Select Project > Regenerate All.

Disabling Autonumbering from Appearing in Output

Oftentimes in your source document(s), you will have autonumbering enabled 
for print delivery purposes (e.g., printed manuals and PDFs). This allows you to 
append autogenerated numbers to your chapters and headings; however, for 
online delivery, you might not want to include autonumbering in your Help 
system. In ePublisher Pro, there is an option in the Style Designer that allows you 
to disable autonumbering in your output. 

To disable autonumbering:

1. Select View > Style Designer.

2. Click on the Paragraph Styles tab.

3. Select the paragraph style that contains the autonumbering.

4. Click on the Options tab.

5. For the option Keep paragraph numbering, choose Disabled.

6. Close the Style Designer.

Modifying Page.asp

If you need to modify the formatting or display of any of the company 
information that displays at the top or bottom of your output pages, then you will 
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need to modify Page.asp. For example, if you would like to change the font that 
your company’s contact information displays in, then you would need to modify 
Page.asp. 

To modify Page.asp:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create a new folder.

h. Name the new folder Pages.

i. Open a new browser window.

j. Navigate to: C:\Program Files\WebWorks\ePublisher 
Pro\Formats\WebWorks Help 5.0\Pages.

k. Copy Page.asp.

l. Close the browser window.

m.Paste Page.asp into the Pages folder of your project format override.

n. Open Page.asp with an HTML or text editor (e.g., Notepad). 

o. Make your changes to Page.asp.

For example, if you want to change the font of your company phone 
number from Times New Roman to Sans-serif, then you will need to find 
the following block of code:

<tr wwpage:condition="company-phone-exists">
<td style="text-align: right; font-size: 12px" 
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wwpage:content="company-phone">
Phone: 512-555-1234
</td>
</tr>

and replace it with:

<tr wwpage:condition="company-fax-exists">
<td style="text-align: right; font-size: 12px; font-
family: sans-serif" wwpage:content="company-fax">
Fax: 512-555-5678
</td>
</tr>

p. Save Page.asp.

q. In your ePublisher Pro project, select Project > Rengenerate All.

Creating Popups

To create popup windows, there must be a link between the hot text and the 
content it will display; after the popup links have been created, popups may be 
implemented by using marker styles or paragraph styles. Once you set up the 
hyperlinks in your source document and apply paragraph or marker styles to your 
content, you will need to assign popup behavior to your paragraph and marker 
styles.

Using Marker Styles to Create Popups

The three marker styles that are involved in creating usable popups are Popup, 
PopupOnly, and PopupEnd. These markers will be inserted into the source 
document to specify what content will be displayed through the popup window 
and whether or not the popup content will display in only a popup window or in 
both a popup window and through a clickable link. After the popup markers have 
been properly embedded in the source document(s), popup behavior needs to be 
assigned to the paragraph styles in the project.

Here are the popup behaviors that can be assigned to marker styles:

• Popup start: Use this option to designate this marker style as the starting 
point for popup content. 

• Popup start with no output: Use this option to designate this marker style 
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as the starting point for popup content.

• Popup end: Use this option to designate this maker as the ending point for 
popup content.

To display popups through a window and a clickable link:

1. Create the hyperlink between the hot text and the content to be displayed and 
ensure that the link resolves in the document. If you have problems creating 
the hyperlink, refer to your authoring tool’s Help documentation for 
information on creating hyperlinks.

Note:  If you have more than one paragraph in the popup window the 
hyperlink should go to the first paragraph.

2. Place the insertion point at the beginning of the content to be displayed in the 
popup window.

3. Do one of the following:

■ For Adobe FrameMaker:

a. Go to Special→Marker.

b. Select Edit... from the Marker Type drop-down menu.

c. Create a custom marker named Popup.

d. Click Add.

e. Click Done. 

f. Choose Popup from the Marker Type drop-down menu.

g. Leave the Marker Text blank.

h. Insert the new Popup marker.

i. Place the insertion point at the end of the content to be displayed in the 
popup window.

j. Select Edit... from the Marker Type drop-down menu.

k. Create a custom marker named PopupEnd.

l. Leave the Marker Text blank.

m.Insert the new PopupEnd marker.
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■ For Microsoft Word:

a. Place the insertion point at the beginning of the content to be displayed in 
the popup window.

b. From the menu bar in Word, go to WebWorks→Markers.

c. Choose Popup from the list of markers.

d. Leave the Value blank.

e. Click OK to insert the marker.

f. From the menu bar in Word, go to WebWorks →  Markers.

g. Choose PopupEnd from the list of markers.

h. Leave the Value field blank.

i. Click OK to insert the PopupEnd marker.

4. In your project, select Project > Scan All Documents.

5. After the scanning process is complete, select View > Style Designer.

6. Click on the Marker Styles tab.

7. Select the Popup marker style.

8. From the Options tab, click on the drop-down button located in the Value 
field of the Marker type option.

9. Select the popup marker behavior Popup start.

10. Select the PopupEnd marker style.

11. From the Options tab, click on the drop-down button located in the Value 
field of the Marker type option.

12. Select the popup marker behavior Popup end.

13. Close the Style Designer.

14. Select Project > Regenerate All.

To display popups through a window only:

1. Create the hyperlink between the hot text and the content to be displayed and 
ensure that the link resolves in the document. If you have problems creating 
the hyperlink, refer to your authoring tool’s Help documentation for 
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information on creating hyperlinks.

Note:  If you have more than one paragraph in the popup window the 
hyperlink should go to the first paragraph.

2. Place the insertion point at the beginning of the content to be displayed in the 
popup window.

3. Do one of the following:

■ For Adobe FrameMaker:

a. Go to Special→Marker.

b. Select Edit... from the Marker Type drop-down menu.

c. Create a custom marker named PopupOnly.

d. Click Done. Choose Popup from the Marker Type drop-down menu.

e. Leave the Marker Text blank.

f. Insert the new PopupOnly marker.

g. Place the insertion point at the end of the content to be displayed in the 
popup window.

h. Select Edit... from the Marker Type drop-down menu.

i. Create a custom marker named PopupEnd.

j. Leave the Marker Text blank.

k. Insert the new PopupEnd marker.

■ For Microsoft Word:

a. From the menu bar in Word, go to WebWorks > Markers.

b. Choose PopupOnly from the list of markers.

c. Leave the Value blank.

d. Click OK to insert the marker.

e. From the menu bar in Word, go to WebWorks > Markers.

f. Choose PopupEnd from the list of markers.

g. Leave the Value field blank.
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h. Click OK to insert the PopupEnd marker.

4. In your project, select Project > Scan All Documents.

5. After the scanning process is complete, select View > Style Designer.

6. Click on the Marker Styles tab.

7. Select the PopupOnly marker style.

8. From the Options tab, click on the drop-down button located in the Value 
field of the Marker type option.

9. Select the popup marker behavior Popup start with no output.

10. Select the PopupEnd marker style.

11. From the Options tab, click on the drop-down button located in the Value 
field of the Marker type option.

12. Select the popup marker behavior Popup end.

13. Close the Style Designer.

14. Select Project > Regenerate All.

Using Paragraph Styles to Create Popups

With ePublisher Pro, you can use paragraph styles to create popups. There are 
two ways to do this: you can either create unique paragraph styles in your source 
document(s) dedicated solely to popup content and assign popup behavior to the 
paragraph styles using the Style Designer, or you can use the Document Designer 
to assign popup behavior to specific paragraphs in your output. In the latter 
method, you do not have to designate any styles solely for popup content. The 
popup content can use any existing paragraph style in your source document(s).

The major difference between the two methods is that by using the Style 
Designer, you are assigning popup behavior to all content in your source 
document(s) that use that particular paragraph style, but by using the Document 
Designer, you are assigning popup behavior only to that instance of that 
paragraph style.

Here are the popup behaviors that can be assigned to paragraph styles:

• Define: Use this option if you would like to display the popup text in a 
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window and through a clickable link; however, select this option only if the 
paragraph style is applied to the first paragraph of popup content.

• Define with no output: Use this option if you would like to display the popup 
text only in a window; however, select this option only if the paragraph style 
is applied to the first paragraph of popup content.

• Append: Use this option if the paragraph style is applied to additional 
paragraphs following the first paragraph of popup content; however, select 
this option only if the paragraph style follows a paragraph style whose popup 
option has been set to Define.

• Append with no output: Use this option if the paragraph style is applied to 
additional paragraphs following the first paragraph of popup content; 
however, select this option only if the paragraph style follows a paragraph 
style whose popup option has been set to Define with no output.

To create popups using the Style Designer:

1. In your source document(s), create the hyperlink between the hot text and the 
content that will be displayed in the popup window.

Note:  If you have more than one paragraph in the popup window the 
hyperlink should go to the first paragraph.

2. Create a unique paragraph style in your source document. 

Note:  This paragraph style will only be applied to the content that will 
appear in the popup window. If the popup window will contain more than one 
paragraph, you will need to create a second paragraph style and apply it to 
any paragraphs following the first paragraph that should appear in the popup 
window.

3. In your project, select View > Style Designer.

4. Click on the Paragraph Styles tab.

5. Select the paragraph style that you would like to modify.

6. Click on the Options tab.

7. For the Popup option, click on the drop-down button and select one of the 
popup behaviors (Define, Define with no output, Append, or Append with no 
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output). For information on popup options, please see “Using Paragraph 
Styles to Create Popups” on page 21.

8. Close the Style Designer.

9. Select Project > Regenerate All.

To create popups using the Document Designer:

1. Create the hyperlink between the hot text and the content that will be 
displayed in the popup window. 

Note:  If you have more than one paragraph in the popup window the 
hyperlink should go to the first paragraph.

2. In the Document Manager, select the document in which the content that will 
be displayed in the popup window resides. 

3. Select Project > Display Preview to generate a preview for this document.

4. In the preview, select the first paragraph of the content that will be displayed 
in the popup window.

5. From the Document Designer, click on the Options tab.

6. For the Popup option, click on the drop-down button and select one of the 
popup behaviors (e.g. Define, Define with no output, Append, or Append with 
no output). For more information on popup behaviors, please see “Using 
Paragraph Styles to Create Popups” on page 21.

7. Select Project > Regenerate All.

Creating Related Topics

Topics the author feels are similar to the current topic or that may be of additional 
interest to the user are called Related Topics. Related Topics may be configured 
to display on the click of a button or both on the click of a button and as a list of 
links within the topic.

Related Topics links are essentially cross-references to other corresponding 
topics within your Help system. Instead of displaying cross-references directly in 
your output, you can create a list of Related Topics links. 
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There are two ways Related Topics can display in your output:

1. Related Topics button only – In your online content, the Related Topics list 
will only display within the v popup menu when the user clicks on the 
Related Topics button.

The following illustration shows online content that displays only the Related 
Topics button. When the user clicks on the related topics button, a popup 
menu of Related Topics links will display.

2. Related Topics button and Related Topics links – In your output, you can 
display the Related Topics list within a Related Topicss button as well as 
within the body of your content.

In the following illustration, the Related Topics list displays from a popup 
menu, and it is also included within the content of the topic. 
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To create a Related Topics button and have the Related Topics links display in the 
output, in the source document, you need to create a paragraph style that will 
specifically apply to the Related Topics lists; then, you will need to create a list of 
Related Topics links for that particular section. 

To create the Related Topics list:

1. Identify the topic in which you would like to insert a Related Topics list.

2. Create a unique paragraph style that will be used specifically for the Related 
Topics list.

3. Identify the various topics to which you will be linking from this topic.

Note:  Generally, you should only create one Related Topics list for each 
section of your source document that corresponds to a Help topic. 

For example, if you have specified in your WebWorks ePublisher Pro project 
that there will be a page break at each Heading 1 section, then you should 
only create one Related Topics list for each Heading 1 section within your 
source document.
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4. Create and insert the list of cross-references to the topics you have chosen in 
step 2.

5. Apply the paragraph style you created in step 1 to the Related Topics list.

6. Save the document(s).

7. In WebWorks ePublisher Pro, using either the Style Designer or Document 
Designer, select the paragraph style that you have assigned to your Related 
Topics lists.

8. Click on the Options tab.

9. Find the related-topic option.

10. Click on the drop-down arrow to display the related-topic options.

• Choose define if you want the related topics list to display both within the 
body of your topic and when the related topics button is clicked.

• Choose define-no-output if you want the related topics list to display only 
when the related topics button is clicked.

Creating Context-Sensitive Help

Contextual Help provides immediate assistance without requiring the user to 
leave the context in which he or she is working. It helps answer questions like 
"What is this?" and "Why would I use this?", providing information for a 
particular object and its context.

In many applications, user interface controls (i.e., windows, tabs, buttons, etc.) 
have identifiers.When a user clicks on a Help button in an application dialog, the 
application calls this Help topic; the application relies on the identifier that has 
been implemented to identify the specific topic to be displayed. WebWorks 
ePublisher Pro uses topic IDs as the identifier, in the form of TopicAlias markers, 
to create the bridge between the application and the Help system.

In WebWorks Help, creating context-sensitive Help is a three-step process. First, 
you need to embed TopicAlias markers into your source documents; next, you 
need to assign topic alias marker behavior to your TopicAlias markers through 
the Style Designer; and finally, you need to call WebWorks Help from your 
application using either URL calls or the WebWorks Help API.
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Before you begin:

Collaborate with application developers about defining topic IDs as soon as 
possible. 

Topic IDs must follow these guidelines: 

• Must be unique 

• Must begin with an alphabetical character 

• May contain alphanumeric characters 

• May not contain special characters or spaces, with the exception of 
underscores ( _ )

To embed topic IDs in a FrameMaker document:

1. Navigate, in your source document, to the topic or paragraph that will be used 
as the Help topic. Most often, this is a heading paragraph that has a page 
break defined in WebWorks ePublisher Pro; however, you can choose any 
paragraph in your source document. 

2. Insert a TopicAlias marker in the topic or paragraph using the topic ID as the 
marker value. To do this:

a. Place the insertion point at the beginning of the topic or paragraph.

b. Go to Special→Marker.

c. In the Marker Type drop-down menu select Edit...

d. Name the marker TopicAlias and click Add.

e. TopicAlias should now be the specified Marker Type. Place the topic ID 
for the Marker Text.

f. Click New Marker.

3. Save the document(s).

4. In your WebWorks ePublisher Pro project, scan your documents and generate 
your project.

To embed topic IDs in a Word document:

1. Place the insertion point at the beginning of the topic or paragraph.
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2. Go to WebWorks→Insert TopicAlias marker...

3. Place the topic ID in the available field.

4. Click OK. 

5. Save the document(s).

6. In your WebWorks ePublisher Pro project, scan your documents and generate 
your project.

You will see hidden text (indicated by the dotted line underneath the text) appear 
with the type of marker (TopicAlias) and the value of this marker (topic ID).

Note:  You may need to choose WebWorks > Show/Hide Hidden Text and Fields to 
see the marker you inserted.

WebWorks ePublisher Pro will add these markers to the project and set the 
marker behavior to Topic alias.

To assign topic alias behavior to topic alias markers:

1. In ePublisher Pro, select View > Style Designer. 

Note:  Make sure that you have scanned your source document(s) so that any 
changes to styles have been picked up. 

2. Click on the Marker Styles button. 

3. Select the TopicAlias marker from the list of marker styles.

4. From the Options tab, find the Marker type option. 

5. Click in the Value field next to the option to enable the drop-down menu.

6. Select Topic alias from the list of marker behaviors.

7. Close the Style Designer.

8. Select Project > Regenerate All.

Calling WebWorks Help

Once you have embedded TopicAlias markers into your source document(s) and 
have assigned topic alias behavior to the markers, you are ready to implement 
context-sensitive Help. The next step in creating context-sensitive Help requires 
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you to call WebWorks Help from your application. There are two ways to call 
WebWorks Help: by using standard URLs or by using the WebWorks Help API. 

To call the entire WebWorks Help system using URLs:

■ The call you need to make from your application needs to be in one of the 
following formats:

• http://www.webworks.com/wwp2003/index.htm 

Use this URL call if the WebWorks Help system is stored on a Web server.

• file:///C:/Program Files/YourApplication/Help/index.htm 

Use this URL call if the WebWorks Help system is stored in the end user's 
local file system.

To call an individual topic using URLs:

■ The call you need to make from your application needs to be in one of the 
following formats:

• http://www.webworks.com/wwp2003/index.htm?context=GROUPNAME&
topic=TOPICID, where GROUPNAME is the name of the the first-level 
group in which the topic resides, and TOPICID refers to the marker text 
used in the topic alias marker for that topic.

• file:///C:/Program 
Files/YourApplication/Help/index.htm&context=GROUPNAME&topic=
TOPICID, where GROUPNAME is the name of the first-level group in 
which the topic resides, and TOPICID refers to the marker text used in the 
topic alias marker for that topic.

To call WebWorks Help using the WebWorks Help API:

WebWorks Help incorporates an API that software developers can use to call 
context-sensitive topics in a WebWorks Help system. Using the API instead of 
simple URLs gives the developer increased flexibility and enhanced control.

Benefits of using the API include the following: 

• The API automatically determines the user's default browser and opens it to 
display the correct Help topic. 
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• The API reduces the amount of code software developers must write in order 
to integrate context-sensitive Help. Without the API, developers must code 
their own COM interface to communicate with Internet Explorer on the 
Win-dows platform. This code is provided as part of the WebWorks Help 
API. 

• Using the API can significantly reduce the time required to load an individual 
topic if the Help system is already open in the browser window. If your 
appli-cation calls a topic using a URL instead of the API, the entire frameset, 
includ-ing the WebWorks Help applet, is loaded each time the user invokes 
Help. If the application calls a topic using the API, and the correct helpset is 
already loaded in the browser window, neither the frameset nor the applet is 
reloaded; instead, the topic frame is used to display the correct Help topic. 
This results in a significant performance improvement for users of your 
WebWorks Help system. 

The WebWorks Help API is a C/C++ API and can be used with applications 
written in C, C++, Visual Basic, and Java. We have not yet updated the API for 
WebWorks Help 5.0; however, the WebWorks Help 4.0 API can be used. Just be 
sure not to use any of the Java navigation options, as WebWorks Help 5.0 does 
not include the Java navigation.

The WebWorks Help 4.0.5 API is available for download at 
http://webworks.com/support/downloads.aspx?referrer=WWHAPI.

Customizations Specific to WebWorks Help

This section will cover project customizations specific to WebWorks Help 5.0. 
WebWorks Help specific customizations refer to any project or output 
modifications that can only be applied to WebWorks Help output – such as 
replacing the splash image and using custom icons in the Contents tab.

These types of customizations are specific to WebWorks Help:

• Adding a PDF button to the toolbar

• Replacing the splash image

• Removing the splash page

• Changing the toolbar buttons
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• Changing the background color of the toolbar

• Setting the initial width of the frame

• Controlling the appearance of the hover text in the navigation frame

• Customizing the font properties on all tabs

• Using custom icons in the Contents tab

• Customizing popup topics

• Modifying the appearance of the search message

• Modifying the search rank

• Changing the theme of the Help system

• Modifying the appearance of popups

• Renaming the top-level file

• Modifying the appearance of breadcrumbs

Adding a PDF Button to the Toolbar

In your ePublisher Pro project, you can generate PDFs for each source document 
and/or each top-level group. You can either deliver the PDFs separately from 
your Help system, or you can add a PDF button to your toolbar that will display 
the PDFs in the frameset.

The PDF that displays when you click on the PDF button depends on whether 
you have generated PDFs for the top-level groups or each source document in 
your project. 

In your project, if you have selected to:

• Generate PDFs only for the top-level groups, then when you click the PDF 
button, the PDF for the top-level group in which the currently viewed topic is 
located will display. 

• Generate PDFs only for each source document, then when you click the PDF 
button, the PDF for the source document in which the currently viewed topic 
is located will display.

• Generate PDFs for all source documents and for all top-level groups, then 
when you click the PDF button, the PDF for the source document in which 
the currently viewed topic is located will display.
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For more information on generating PDFs, please see “Creating PDFs” on 
page 62.

To add a PDF button to your toolbar:

1. In ePublisher Pro, select Format > Format Settings. 

2. Find the option Show PDF button.

3. Click in the Value field next to the option to enable the drop-down menu. 

4. Select Enabled.

5. Close the Style Designer.

6. Select Project > Regenerate All.

Replacing the Splash Image

The splash page is the first page that displays in the topic frame when the Help 
set launches initially. By default, WebWorks Help systems display the WebWorks 
splash image; however, you can replace the default splash image with a custom 
image.

To replace the splash image:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:
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Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings and find the Theme setting.

2. Within the images folder, place the image that will be used as the splash 
image.

3. Rename the image splash.jpg.

4. In the ePublisher Pro project, select Project > Regenerate All.

Removing the Splash Page

Initially, when WebWorks Help launches, it displays the splash page; however, 
instead of displaying the splash page, WebWorks Help can display the first topic 
page instead. This means that when the Help system launches, it will take you 
directly to the first topic page of your Help set.

To remove the splash page:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
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project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within that folder, create the following directory structure:

2. Navigate to C:\Program Files\WebWorks\ePublisher Pro\Formats\WebWorks 
Help 5.0\Files\wwhelp\wwhimpl\common\html.

3. Copy first.htm.

4. Paste first.htm into the html folder in the project format override.

5. Rename first.htm to default.htm

6. In ePublisher Pro, select Project > Regenerate All.

Changing the Toolbar Buttons

WebWorks Help systems have a standard toolbar that comes with the following 
buttons:

• Show in Contents button

• Previous button

• Next button

• PDF button

• Related Topics button

• Print button

• E-mail button

These buttons allow you to navigate through the Help system, and they provide 
you with additional features – such as printing a page from the Help set or e-
mailing a link to a topic page. The buttons on the toolbar are actual GIF images 
located in the images folder of your project theme’s diretory; therefore, these 
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standard buttons can either be replaced with another GIF image or removed from 
the toolbar.

Removing or Replacing the Show in Contents Button

The Show in Contents button allows users to synch the topic they are viewing to 
the TOC. 

To remove the Show in Contents button:

1. In ePublisher Pro, go to Format > Format Settings.

2. Find the setting Automatically synchronize the TOC.

3. Change the value to Disabled.

4. Click OK to close the Format Settings dialog box.

To replace the Show in Contents button:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:
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Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings and find the Theme setting.

2. Inside the images folder, place the image that will be used as the Show in 
Contents button.

3. Name the image syncx.gif.

4. In ePublisher Pro, select Project > Regenerate All.

Removing and Replacing the Previous and Next Buttons

The previous button allows users to navigate back to preceding topics in the Help 
system. 

To remove the Previous and Next button:

1. In ePublisher Pro, go to Format > Format Settings.

2. Find the setting Show previous & next toolbar buttons.

3. Change the value to Disabled.

4. Click OK to close the Format Settings dialog box.

To replace the Previous button:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.
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b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g. Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings, and find the Theme setting.

2. Inside the images folder, place the image that will be used as the Previous 
button.

3. Name the image prev.gif.

4. In ePublisher Pro, select Project > Regenerate All.

To replace the Next button:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.
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b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings and find the Theme setting.

2. Inside the images folder, place the image that will be used as the Previous 
button.

3. Name the image next.gif.

4. In ePublisher Pro, go to Project > Regenerate All.

Changing the Background Color of the Toolbar

The toolbar in WebWorks Help 5.0 is composed of a single repeating GIF image: 
toolsbg.gif. This image is located in the images folder of your project’s theme 
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directory. To modify the background color of the toolbar, you will need to modify 
the color of toolsbg.gif with an image editor.

To change the background color of the toolbar:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings and find the Theme setting.

2. Navigate to C:\Program Files\WebWorks\ePublisher Pro\Formats\WebWorks 
Help 5.0\Skins\Lobby_Blue\Files\wwhelp\wwhimpl\common\images.
WebWorks ePublisher Pro Format Guide 39



Formats: WebWorks Help 5.0
Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. 

3. Copy toolsbg.gif.

4. Paste toolsbg.gif into the images folder in the project format override.

5. Open toolsbg.gif with an image editor (e.g., Paint). 

6. Modify toolsbg.gif to reflect the color that will be used as the toolbar 
background and save the changes to the image.

7. In ePublisher Pro, select Project > Regenerate All.

Setting the Initial Width of the Navigation Frame

The navigation frame refers to the pane that contains the Contents, Index, Search, 
and Favorites tabs. When a WebWorks Help system launches, the initial width of 
the navigation frame is set to 300 pixels; however, by modifying wwhelp.htm, 
you can specify the initial width of the navigation frame when the Help set opens 
initially.

To set the initial width of the navigation frame:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:
40 WebWorks ePublisher Pro Format Guide



WebWorks Help 5.0
2. Navigate to C:\Program Files\WebWorks\ePublisher Pro\Formats\WebWorks 
Help 5.0\Files\wwhelp\wwhimpl\js\html.

3. Copy wwhelp.htm.

4. Paste wwhelp.htm into the html folder of the project format override.

5. Open wwhelp.htm with a text or HTML editor (e.g., Notepad).

6. Find the following block of code:

<frameset cols="300,*" onLoad="WWHHelp.fInitStage(0);" 
onKeyDown="WWHFrame_HandleKeyDown((document.all||docume
nt.getElementById||document.layers)?event:null);" 
onKeyPress="WWHFrame_HandleKeyPress((document.all||docu
ment.getElementById||document.layers)?event:null);" 
onKeyUp="WWHFrame_HandleKeyUp((document.all||document.g
etElementById||document.layers)?event:null);">

7. Change 300 (the value for frameset columns) to the width you would like for 
navigation frame.

Note:  The width of the frameset is measured in pixels.

8. Save wwhelp.htm.

9. In ePublisher Pro, select Project > Regenerate All.

Controlling the Appearance of the Hover Text in the Navigation Frame

Hover text refers to the popup window that displays whenever you move your 
mouse over a link on the Contents tab. 
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The appearance of the hover text can be altered by modifying the 
wwhelp_settings.xml file. Within this file, you can modify the appearance of the 
hover text that appears in the navigation frame when the user hovers over any 
topic link. This includes changing the font color, background color, border color, 
and font of the hover text. Within this file, you can also disable the hover text 
from appearing in the navigation frame.

To change the font color of the hover text:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder: Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:
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Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings and find the Theme setting.

2. Navigate to C:\Program Files\WebWorks\ePublisher Pro\Formats\WebWorks 
Help 5.0\Skins\Lobby_Blue\Files\wwhelp\wwhimpl\common\images.

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. 

3. Copy wwhelp_settings.xml.

4. Paste wwhelp_settings.xml into the Lobby_Blue folder in the project format 
override.

5. Open wwhelp_settings.xml with a text or an XML editor (e.g., Notepad).

6. Find the following block of code:

<HoverText enable="true">
    <Font style="font-family: Verdana, Arial, Helvetica, 
sans-serif ; font-size: 8pt" />
    <Colors foreground="#000000" background="#FFFFCC" 
border="#999999" />
    <Size width="150" />
   </HoverText>

7. Replace #000000 with the color HEX value you want to use.

8. Save wwhelp_settings.xml.

9. In ePublisher Pro, select Project > Regenerate All.

To change the background color of the hover text:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.
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b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings, and find the Theme setting.

2. Navigate to C:\Program Files\WebWorks\ePublisher Pro\Formats\WebWorks 
Help 5.0\Skins\Lobby_Blue\Files\wwhelp\wwhimpl\common\images.

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. 

3. Copy wwhelp_settings.xml.

4. Paste wwhelp_settings.xml into the Lobby_Blue folder in the project format 
override.

5. Open wwhelp_settings.xml with a text or an XML editor (e.g., Notepad).

6. Find the following block of code:

<HoverText enable="true">
    <Font style="font-family: Verdana, Arial, Helvetica, 
sans-serif ; font-size: 8pt" />
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    <Colors foreground="#000000" background="#FFFFCC" 
border="#999999" />
    <Size width="150" />
   </HoverText>

7. Replace #FFFFCC with the color HEX value you want to use.

8. Save wwhelp_settings.xml.

9. In ePublisher Pro, go to Project > Regenerate All.

To change the font and font size of the hover text:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder: Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings and find the Theme setting.

2. Navigate to C:\Program Files\WebWorks\ePublisher Pro\Formats\WebWorks 
Help 5.0\Skins\Lobby_Blue\Files\wwhelp\wwhimpl\common\images.
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Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. 

3. Copy wwhelp_settings.xml.

4. Paste wwhelp_settings.xml into the Lobby_Blue folder in the project format 
override.

5. Open wwhelp_settings.xml with a text or an XML editor (e.g. Notepad).

6. Find the following block of code:

<HoverText enable="true">
    <Font style="font-family: Verdana, Arial, Helvetica, 
sans-serif ; font-size: 8pt" />
    <Colors foreground="#000000" background="#FFFFCC" 
border="#999999" />
    <Size width="150" />
   </HoverText>

7. To change the font, replace “Verdana, Arial, Helvetica, sans-serif” with the 
font you want to use.

8. To change the font size, replace “8pt” with the font size you want to use.

9. Save wwhelp_settings.xml.

10. In ePublisher Pro, select Project > Regenerate All.

To change the border color of the hover text:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.
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g. Within the format target’s folder, create the following directory structure:

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings and find the Theme setting.

2. Navigate to C:\Program Files\WebWorks\ePublisher Pro\Formats\WebWorks 
Help 5.0\Skins\Lobby_Blue\Files\wwhelp\wwhimpl\common\images.

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. 

3. Copy wwhelp_settings.xml.

4. Paste wwhelp_settings.xml into the Lobby_Blue folder in the project format 
override.

5. Open wwhelp_settings.xml with a text or an XML editor (e.g., Notepad).

6. Find the following block of code:

<Panels>
   <HoverText enable="true">
    <Font style="font-family: Verdana, Arial, Helvetica, 
sans-serif ; font-size: 8pt" />
    <Colors foreground="#000000" background="#FFFFCC" 
border="#999999" />
    <Size width="150" />
   </HoverText>

7. Replace #999999 with the color HEX value you want to use.

8. Save wwhelp_settings.xml.

9. In ePublisher Pro, select Project > Regenerate All.

To disable the hover text:
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1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings and find the Theme setting.

2. Navigate to C:\Program Files\WebWorks\ePublisher Pro\Formats\WebWorks 
Help 5.0\Skins\Lobby_Blue\Files\wwhelp\wwhimpl\common\images.

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. 

3. Copy wwhelp_settings.xml.

4. Paste wwhelp_settings.xml into the Lobby_Blue folder in the project format 
override.

5. Open wwhelp_settings.xml with a text or an XML editor (e.g., Notepad).

6. Find the following block of code:
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<Panels>
   <HoverText enable="true">
    <Font style="font-family: Verdana, Arial, Helvetica, 
sans-serif ; font-size: 8pt" />
    <Colors foreground="#000000" background="#FFFFCC" 
border="#999999" />
    <Size width="150" />

   </HoverText>

7. Change the value in <HoverText enable="true"> from “true” to 
“false”.

8. Save wwhelp_settings.xml.

9. In ePublisher Pro, select Project > Regenerate All.

Changing the Font Color on All Tabs in the Navigation Frame

The tabs in the navigation frame all share the same font and text style properties. 
These style properties are specified in the wwhelp_settings.xml file, which is 
located in your project’s theme directory. 

To change the font color on all the tabs in the navigation frame:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:
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Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings and find the Theme setting.

2. Navigate to C:\Program Files\WebWorks\ePublisher Pro\Formats\WebWorks 
Help 5.0\Skins\Lobby_Blue\Files\wwhelp\wwhimpl\common\images.

Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. 

3. Copy wwhelp_settings.xml.

4. Paste wwhelp_settings.xml into the Lobby_Blue folder in the project format 
override.

5. Open wwhelp_settings.xml with a text or an XML editor (e.g., Notepad).

6. Find the following block of code:

<Tabs>
   <DefaultColors foreground="#666666" />
   <SelectedColors foreground="#FFFFFF" />
  </Tabs>

7. Replace #666666 and/or #FFFFFF with the color HEX value you want you 
want to use.

8. Save wwhelp_settings.xml.

9. In ePublisher Pro, select Project > Regenerate All.

Using Custom Icons on the Contents Tab

When you navigate through the TOC on the contents tab, you will see that there 
are two types of icons: open and closed book icons. Open book icons represent 
expanded TOC levels, and closed book icons represent unexpanded TOC levels.
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All of the icons displayed on the contents tab are actual GIF images (fc.gif and 
fo.gif) located in the images folder of your project’s theme directory. By creating 
a project format override to replace fc.gif and fo.gif, you can use your own 
custom TOC icons instead.

To replace the closed book icon on the Contents tab:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:

Expanded 
book icon

Closed book 
icon
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Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings and find the Theme setting.

2. Inside the images folder of the project format override, place the image that 
will be used as the closed book icon.

3. Name the image fc.gif.

4. In ePublisher Pro, select Project > Regenerate All.

To replace the open book icon on the Contents tab:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:
52 WebWorks ePublisher Pro Format Guide



WebWorks Help 5.0
Note:  Replace the Lobby_Blue folder with the name of the skin or theme 
that is used in the project. If the theme consists of two words, separate the 
words with an underscore (e.g., Architect_Red, Aero_Blue, 
Freeform_Green, etc.). To determine what theme the project is using, go to 
Format > Format Settings and find the Theme setting.

2. Inside the images folder of the project format override, place the image that 
will be used as the open book icon.

3. Name the image fo.gif.

4. In ePublisher Pro, select Project > Regenerate All.

Modifying the Appearance of the Search Message

In WebWorks Help, when users click on the Search tab, the message “Type in the 
word(s) to search for:” displays. Once the user types in a word to search for and 
selects the Go button, the “(Searching)” message will display briefly in the 
search results box. The appearance of these messages is controlled by the h2 and 
h3 HTML tags, and these tags are located in the search.js file; therefore, in order 
to modify the appearance of the search messages, you will need to specify the 
style properties for h2 and h3 in a separate CSS file. 

To change the appearance of the message “Type in the word(s) to search for:”, 
you will need to create a style definition for h2, and to modify the appearance of 
the “(Searching)” message, you will need to create a style definition for h3. After 
you have specified the font properties in a CSS file for h2 and/or h3, you will 
need to reference the CSS file in the search.js file. 
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To modify the appearance of the search messages:

1. Using a text or HTML editor, create a CSS file that contains style properties 
for h2 and h3. For example, your CSS file can contain the following:

/* Controls appearance of the “Searching” message */
h2
{
color: #FF00FF;
text-decoration: underline;
font-size: 12pt;
}

/* Controls appearance of the “Searching” message */

h3
{
color: #FF00FF;
text-decoration: none;
font-size: 14pt;
}

2. Save the CSS file to a location on your system (e.g., your desktop).

3. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.

d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create the following directory structure:
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4. Navigate to C:\Program Files\WebWorks\ePublisher Pro\Formats\WebWorks 
Help 5.0\Files\wwhelp\wwhimpl\js\scripts.

5. Copy search.js.

6. Paste search.js into the scripts folder of the project format override.

7. Open search.js with a text editor (e.g., Notepad).

8. Find the following block of code:

// Display initializing message
//
HTML.fAppend(“<h2>” + 
WWHFrame.WWHJavaScript.mMessage.mInitializingMessage + 
“</h2>\n”);

9. Replace it with:

// Display initializing message
// 
HTML.fAppend(“<link rel=\”StyleSheet\” 
href=\”../document.css\”type=\”text/css\”/>
HTML.fAppend(“<h2>” + 
WWHFrame.WWHJavaScript.mMessage.mInitializingMessage + 
“</h2>\n”);

where “../document.css\” refers to the location where your CSS file is 
located.

10. Find both instances of the following block of code:

// Display searching message
//
HTML.fAppend(“<h2>” + 
WWHFrame.WWHJavaScript.mMessages.mSearchSearchingMessage + 
“</h2>\n”);

11. Replace each instance with:
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// Display searching message
//
HTML.fAppend(“<link rel=\”StyleSheet\” 
href=\”../document.css\”type=\”text/css\”/>
HTML.fAppend(“<h2>” + 
WWHFrame.WWHJavaScript.mMessages.mSearchSearchingMessage + 
“</h2>\n”);

where “../document.css\” refers to the location where your CSS file is 
located.

12. Find the following block of code:

// Display search message and/or prepare results for 
display
//
if (this.mSavedSearchWords.length == 0)
}
HTML.fAppend(“<h3>” + 
WWHFrame.WWHJavaScript.mMessages.mSearchDefaultMessage + 
“</h3>\n”);

13. Replace it with:

// Display search message and/or prepare results for 
display
//
if (this.mSavedSearchWords.length == 0)
}
HTML.fAppend(“<link rel=\”StyleSheet\” 
href=\”../document.css\”type=\”text/css\”/>
HTML.fAppend(“<h3>” + 
WWHFrame.WWHJavaScript.mMessages.mSearchDefaultMessage + 
“</h3>\n”);

where “../document.css\” refers to the location where your CSS file is 
located.

14. Save search.js.

15. In ePublisher Pro, select Project > Regenerate All.

Modifying the Search Rank

The search results display in the search pane when a user types in a word to 
search for and clicks on the Go button. When the search results display, they are 
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sorted by the ranking relevancy. 

Ranking relevancy is calculated based on the scoring preference you have set for 
your tags in wwhelp_files.xml. By default, WebWorks Help assigns relevancy 
rankings based on where in a document a particular item is found. 

For example, if you have the scoring preference, or weight, for Heading 1 set to 
25 and the weight for Heading 2 set to 15, then any search term that is found in a 
Heading 1 will return a higher relevancy than if the search term is located in a 
Heading 2.

Here is how the ranking relevancy is calculated:

Let’s say that you search for the word “popup,” and that word appears both in a 
Heading 1 and a Heading 2 on one page and in a Heading 1 on another page. The 
search should return two results, and the results will be sorted by the ranking 
relevancy.

To get the ranking relevancy, WebWorks Help takes the score of each search 
result and divides it by the highest score found. To get the score of each search 
result, the scoring preference for each tag is used.

For example. let’s say that Heading 1 has a scoring preference of 25 and Heading 
2 has a scoring preference of 15. If the word “popup” appears in a Heading 1 and 
a Heading 2 on a topic page, then the score for that word on that page is 40 (or 25 
+ 15). If the word “popup” appears in a Heading 1 on another topic page, then the 
score for that word on that page is 25 (the scoring preference for a Heading 1). 

Therefore, if 40 is the highest score that “popup” returns, the ranking relevancy 
of the first search result would be 100% or 40/40 x 100%, and the ranking 
relevancy for the second search result would be 38% or 15/40 x 100%.

To modify the ranking relevancy for search results:

1. Create a project format override. To do this:

a. In ePublisher Pro, go to View > User Files.

b. Go up a directory level; this directory should contain the .wep file and the 
Files, Data, Logs, and Output folders.

c. Create a new folder.
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d. Name the folder Formats.

e. Within the Formats folder, create a new folder.

f. Assign the new folder the name of the format target that is selected for the 
project (e.g., WebWorks Help 5.0).

Note:  Folder names in a format override are case-sensitive.

g. Within the format target’s folder, create a new folder.

h. Name the new folder Transforms.

i. Navigate to C:\Program Files\WebWorks\ePublisher 
Pro\Formats\WebWorks Help 5.0\Transforms. 

j. Copy wwhelp_files.xml.

k. Paste wwhelp_files.xml into the Transforms folder of your project format 
override.

l. Open wwhelp_files.xml with a text or XML editor.

m.Find the following block of code:

<ScoringPrefs>
    <meta name="keywords" weight="100"/>
    <meta name="description" weight="50"/>
    <meta name="summary" weight="50"/>
    <title weight="20"/>
    <h1 weight="15"/>
    <h2 weight="10"/>
    <caption weight="10"/>
    <h3 weight="7"/>
    <th weight="5"/>
    <h4 weight="5"/>
    <h5 weight="4"/>
    <h6 weight="3"/>
    <h7 weight="2"/>
  </ScoringPref>

n. Modify the weight attributes for any of the tags (e.g., h1, h2, etc.) that you 
wish to change.

o. Save wwhelp_files.xml.

p. In ePublisher Pro, select Project > Regenerate All.
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Selecting a Theme

In WebWorks Help 5.0, you can easily control the appearance of your Help set by 
choosing a theme. You can choose from 17 different themes; each WebWorks 
Help 5.0 theme comes with its own custom skin, which controls the color of the 
toolbar, navigation frame, tabs, and splash image.

To choose a theme for WebWorks Help:

1. In ePublisher Pro, select Format > Format Settings.

2. Find the setting Theme.

3. Click on the value field to see the drop-down menu.

4. Select a theme from the drop-down menu.

5. Click OK to close the Format Settings dialog box.

6. Select Project > Regenerate All. 

Renaming the Top-Level File

When you generate output for your project, a top level file will be created. This 
file contains the entire Help system – such as the table of contents, every topic 
page in your project, the index, etc. The top-level file is the file that end users 
will launch in order to view the Help set in its entirety. By default, the top level 
file is named index.html, but you can name the top-level file anything you want 
as long as you provide it with an .html or .htm extension.

To rename the top level file:

1. In ePublisher Pro, select Format > Format Settings.

2. Find the setting Top level filename.

3. From the value field, highlight index.html.

4. Type in the name you would to use for the top-level filename.

5. Click OK to close the Format Settings dialog box.

6. Select Project > Regenerate All.

Assigning a Page Style to Popup Windows
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If you have popups in your content, the appearance of the popup windows is 
controlled by Page.asp; therefore, the popup windows will essentially take on the 
same look and feel as the rest of your topic pages – from breadcrumbs to 
company information. If you want to assign a different page style than Page.asp 
to your popup windows, you will need to create a new page style in ePublisher 
and assign it to your popup paragraph styles.

Note:  If you are using marker styles to create popups, you cannot use page styles 
to control the appearance of your popup windows. This method is only applicable 
to popups created with paragraph styles.

To assign a page style to popup windows:

1. In ePublisher Pro, select View > Style Designer.

2. Click on the Page Styles tab.

3. Click on the New Style button.

Note:  A new page style called Untitled will be added. 

4. Click on the new page style Untitled to rename it. For example, if you are 
only going to use this page style for popup windows, name the new page style 
Popup Page Style.

5. From the Properties tab and the Options tab, select the options that you would 
like to assign to this page style.

6. Once you have finished creating your page style, click on the Paragraph 
Styles tab.

7. Select your popup paragraph style. 

8. Click on the Options tab.

9. Find the option Popup page style.

10. Click on the drop-down button.

11. Select the page style you would like to assign to this popup paragraph style.

12. Close the Style Designer.

13. Select Project > Regenerate All.
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WebWorks Help Output
When you generate output from the WebWorks Help format, WebWorks 
ePublisher Pro creates all the files required to produce a WebWorks Help system. 
The index.html file contains the complete content of your converted source 
documents. This is the file you distribute to end users. 

The following table contains and identifies the output files that are produced 
from a WebWorks Help project.

Generating Output for the Entire Project

When you generate output for all groups in your project, you are generating an 
entry-point file for each first-level group and HTML files for each source 
document in your project. Depending on where you have specified page splits, a 
new HTML page will be created at each page split. You want to generate output 
for all of the groups in your project when you are deploying your output, merging 
your Help files, or generating the final, completed Help set.

File Type Extension Description

Output pages .html HTML files that conform to the requirements 
of the WebWorks Help format. Help authors 
often refer to these HTML files as topic files. 
These files are incorporated into the 
compressed Help set file, and you do not need 
to distribute them to end users. 

Output graphics .gif, .png., 
.jpeg

Graphics files (file format depends on how you 
map and define graphics styles in your 
project). These files are incorporated into the 
compressed helpset file, and you do not need 
to distribute them to end users. 

Cascading Style 
Sheets

.css Cascading Style Sheet files that conform to the 
CSS1 specification. These files are 
incorporated into the compressed Help set file, 
and you do not need to distribute them to end 
users. 
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To generate online output for your entire project:

1. Click to select the topmost group in your project. 

2. Choose Project→Generate All.

Generating Output for a Single Group

When you generate output for a single group, you are creating the entry-point file 
and HTML files for the source documents within that specific group. In 
WebWorks ePublisher Pro, there is an option to target a group to generate output 
with. When you choose the Generate option in WebWorks ePublisher Pro, you 
are generating output for all of the source documents within that specific group. 
If you generate output for a first-level group, then output will be produced for all 
of the source documents found within that group as well as its subgroups.

For example, if you have already generated output for the other groups in your 
project, and you have made some slight modifications to a single group, then you 
would want to generate output for that single group. This will reduce the amount 
of time that it takes WebWorks ePublisher Pro to generate output for your project.

To generate online output for a selected first-level group or subgroup:

1. From the Document Manager, click on the first-level group or subgroup for 
which you want to generate online output. 

2. Choose Project→Generate.

Creating PDFs

In ePublisher Pro, there are two PDF options that you can enable in the Format 
Settings dialog to generate PDFs: Generate a PDF per document or Generate a 
PDF for each top-level group. The Generate a PDF per document option will 
generate a PDF for each source document in your project, and the Generate a 
PDF per top-level group option will generate a single PDF for all the source 
documents within a top-level group.

To generate PDFs for each source document:
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1. Select Format > Format Settings.

2. Find the option Generate a PDF per document.

3. Click in the Value field to enable the drop-down menu.

4. Select Enabled.

5. Close the Format Settings dialog box.

6. Select Project > Regenerate All.

To generate PDFs for each top-level group:

1. Select Format > Format Settings.

2. Find the option Generate a PDF per top level group.

3. Click in the Value field to enable the drop-down menu.

4. Select Enabled.

5. Close the Format Settings dialog box.

6. Select Project > Regenerate All.

Creating Merged Help

To create multivolume Help, you need to set up at least two first-level groups in 
your Document Manager. The name of your first-level groups will serve as the 
book names in your Help set. 

When you merge the output files from the groups within your project, you are 
taking the TOC, index, and search data from each top-level group’s generated 
entry-point file, and combining that information into a single, consolidated 
system. Currently, when you generate output for your project, each first-level 
group will generate its own entry-point file. In order to create one cohesive Help 
set, you will need to merge the entry-point files into one consolidated Help set.

By default, if you have created several first-level groups in your project, 
ePublisher Pro will automatically create a merged or multivolume Help set for 
you. Once you generate output for your project, the multivolume Help set will be 
located in the Merged Output group in the Output Explorer, and it will be named 
index.html.
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When you launch your mutivolume Help set, you will notice that the names of 
your first-level groups will display in the TOC. If you want to organize and group 
your first-level groups under a different book name not specified in the 
Document Manager, or if you would like to reorganize the TOC of your 
multivolume Help set, you will need to use the Merge Settings feature in 
ePublisher Pro. 

To organize the TOC of a multivolume Help set:

1. In ePublisher Pro, select Format > Merge Settings.

You will see a listing of all your first-level groups under the Hierarchy 
section.

2. Click and drag any of your first level groups to reposition them in the TOC 
hierarchy.

3. Close the Merge Settings dialog box.

4. Select Project > Regenerate All.

To add a book to your multivolume Help set:

1. In ePublisher Pro, select Format > Merge Settings.

2. Click on the Add button.

A TOC entry, or book, called Untitled Topic will be added to your 
TOC hierarchy.

3. Double-click on Untitled Topic to rename it.

4. Click and drag any of your first-level groups into the new TOC entry.

5. Close the Merge Settings dialog box. 

6. Select Project > Regenerate All.

To rename first-level groups in the TOC:

1. In ePublisher Pro, select Format > Merge Settings.

You will see a listing of all of your first-level groups under the Hierarchy 
section.

2. Click to select any of your first-level groups in the TOC hierarchy.
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3. In the Table of contents title field, type in the name you would like to assign 
the first-level group. This is the name that will appear in the TOC.

4. Close the Merge Settings dialog box.

5. Select Project > Regenerate All.

To change the name of Help set that displays in the title bar of the browser:

1. In ePublisher Pro, select Format > Merge Settings.

2. In the Merge Title field, type in the name you would like to display in the title 
bar of the browser when the Help set initially launches.

Delivering WebWorks Help

After you have finalized changes and have generated output for your project, you 
will need to deliver the final product to be implemented into your application or 
posted on the Web. 

When you generate output for your project, all output will be stored in the Output 
folder of your project’s directory. To access your Output folder, please see 
“Viewing Output Files with the Output Directory” on page 67. 

The Output directory contains the entry-point file, index.html, that you use in 
order to launch the entire Help set, all of the individual topic pages, all generated 
CSS files, PDFs, images, and necessary WebWorks Help components that enable 
the Help system to work. Everything within the Output folder needs to be 
delivered. 

Viewing Output

The Output Explorer gives you access to all of the output files WebWorks 
ePublisher Pro generates from the source documents in your project. When you 
create a new project, WebWorks ePublisher Pro creates an output directory 
structure for the files you will generate. When you generate output for your 
project, the generated output files will populate the output directory structure and 
will be accessible from the Output Explorer; this means that you can double-click 
on any of the files located in the Output Explorer to view the generated output. 
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There are two types of generated output files you can view in the Output 
Explorer: each individual HTML page generated according to the page breaks 
inserted in your project and the compiled Help set. The entry-point file to each 
type of output file depends on whether the source document or the group is 
selected in the Document Manager. 

When you select any of the first-level groups in the Document Manager, the 
Output Explorer displays a group with the same name as the group selected in the 
Document Manager; underneath this group, a Navigation group and a Reports 
group will display. When a first-level group is selected in the Document 
Manager, the Output Explorer will display the generated entry-point file under 
the Navigation group, and any reports associated with the format will display 
under the Reports group.

Viewing the Entry-Point File with the Output Explorer

The entry-point file comprises all of the generated output files contained within 
the first-level group, and it is the file that launches your Help set. Each first-level 
group has its own entry-point file.

To view the entry-point file with the Output Explorer:

1. In the Document Manager, click to select the first-level group whose entry-
point file you would like to see.

2. Double-click on the entry-point file located under the Navigation group.

Viewing the Generated Output Files with the Output 
Explorer

When you generate output, each source document will produce its own HTML 
files based on the page breaks inserted in your project. A page break indicates 
that a new page will be produced at that break.

To view HTML output files with the Output Explorer:

1. In the Document Manager, click to select the source document whose HTML 
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files you would like to see.

2. Double-click on the HTML files located under the Files group.

Viewing Output Files with the Output Directory

When you generate output for your project, all of the generated output pages are 
placed into the Output Directory. Each first-level group in your project will have 
its own folder in the Output Directory; each folder will contain the PDFs, entry-
point files, and HTML files that are associated with the first-level group.

To access the files in the Output Directory, choose View > Output Directory.
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